mailbhupal

Tutorial For Zte Mc315 Cdma 1x Reliance On Linux

23 posts in this topic

By

Ram Bhupal Reddy

IIIT, Hyderabad.

Two steps to enable ZTE MC315 CDMA 1X Reliance.

Step 1. Insert the card and do dmesg as root

output : 0.0: ttyS0 at I/O 0x2e8 (irq = 3) is a 16C950/954

Step 2. edit /etc/wvdial.conf

[Dialer Reliance]

Modem = /dev/ttyS0

Baud = 57600

SetVolume = 0

Dial-AT-OK ATDT Command =

Init1 = ATZ

FlowControl = Hardware (CRTSCTS)

Phone = #777

Username =

Password =

New PPPD = yes

Carrier Check = no

Stupid Mode = 1

Before running wvdial Reliance do following

The trick is simple - you have to play with the UART and the baud_base.

Just run setserial on your machine and it will give the following output for UART and baud_base

* uart set UART type (none, 8250, 16450, 16550, 16550A,

16650, 16650V2, 16750, 16850, 16950, 16954)

* baud_base set base baud rate (CLOCK_FREQ / 16)

What i did was that i kept on changing my UART and kept the baud_base as 230400. When I changed my UART to 16550A. And i got connected to the internet running wvdial Reliance

[Fyi: I am sending this information using ZTE MC315 CDMA 1X Reliance connected on OS FC5.]

Share this post


Link to post
Share on other sites

Thanks for sharing your findings !

mods, please pin this topic

Share this post


Link to post
Share on other sites

Done !

Share this post


Link to post
Share on other sites

mailbhupal,

nice tutorial. got it done within minutes. thanks.

- k

(Ubuntu Fawn Live CD on dell laptop lattitude d620)

Share this post


Link to post
Share on other sites

Hi,

I am having ZTE MC315 CDMA 1X Reliance data card. I am using Ubuntu 7.04 OS. I tried the steps specified by you.

Below I listed my wvdial.conf file

*****************************************

#[Dialer Reliance]

[Dialer Default]

Modem = /dev/ttyS3

Baud = 230400

SetVolume = 0

Dial-AT-OK ATDT Command =

Init1 = ATZ

FlowControl = Hardware (CRTSCTS)

Phone = #777

Username = (my mobile no)

Password = (my password)

New PPPD = yes

Carrier Check = no

Stupid Mode = 1

******************************************

After saving wvdial.conf file, I executed following commands. But they are not working.

Following commands are not working in my machine

* set UART type (none, 8250, 16450, 16550, 16550A,16650, 16650V2, 16750, 16850, 16950, 16954)

16650, 16650V2, 16750, 16850, 16950, 16954)

bash: syntax error near unexpected token `('

* baud_base set base baud rate (CLOCK_FREQ / 16)

bash: syntax error near unexpected token `('

************************************************

Then I ran wvdial. But I got the following result "Modem not responding"

root@mylaptop:/etc# wvdial

--> WvDial: Internet dialer version 1.56

--> Initializing modem.

--> Sending: ATZ

--> Sending: ATQ0

--> Re-Sending: ATZ

--> Modem not responding.

How to solve this problem. Please help me.

Tahnks & Regards,

Sivaraj.v

Share this post


Link to post
Share on other sites

setserial command does not give any output in ubuntu 7.04 feisty fawn

Share this post


Link to post
Share on other sites
By

Ram Bhupal Reddy

IIIT, Hyderabad.

Two steps to enable ZTE MC315 CDMA 1X Reliance.

Step 1. Insert the card and do dmesg as root

output : 0.0: ttyS0 at I/O 0x2e8 (irq = 3) is a 16C950/954

Step 2. edit /etc/wvdial.conf

[Dialer Reliance]

Modem = /dev/ttyS0

Baud = 57600

SetVolume = 0

Dial-AT-OK ATDT Command =

Init1 = ATZ

FlowControl = Hardware (CRTSCTS)

Phone = #777

Username =

Password =

New PPPD = yes

Carrier Check = no

Stupid Mode = 1

Before running wvdial Reliance do following

The trick is simple - you have to play with the UART and the baud_base.

Just run setserial on your machine and it will give the following output for UART and baud_base

* uart set UART type (none, 8250, 16450, 16550, 16550A,

16650, 16650V2, 16750, 16850, 16950, 16954)

* baud_base set base baud rate (CLOCK_FREQ / 16)

What i did was that i kept on changing my UART and kept the baud_base as 230400. When I changed my UART to 16550A. And i got connected to the internet running wvdial Reliance

[Fyi: I am sending this information using ZTE MC315 CDMA 1X Reliance connected on OS FC5.]

I have followed your instructions, until I get to setserial. How do you precisely use this command? I've searched already, but the "help" is no help at all... So could you please tell us, or post a link with specific instructions?

Thanks in advance.

Share this post


Link to post
Share on other sites
By

Ram Bhupal Reddy

IIIT, Hyderabad.

Two steps to enable ZTE MC315 CDMA 1X Reliance.

Step 1. Insert the card and do dmesg as root

output : 0.0: ttyS0 at I/O 0x2e8 (irq = 3) is a 16C950/954

Step 2. edit /etc/wvdial.conf

[Dialer Reliance]

Modem = /dev/ttyS0

Baud = 57600

SetVolume = 0

Dial-AT-OK ATDT Command =

Init1 = ATZ

FlowControl = Hardware (CRTSCTS)

Phone = #777

Username =

Password =

New PPPD = yes

Carrier Check = no

Stupid Mode = 1

Before running wvdial Reliance do following

The trick is simple - you have to play with the UART and the baud_base.

Just run setserial on your machine and it will give the following output for UART and baud_base

* uart set UART type (none, 8250, 16450, 16550, 16550A,

16650, 16650V2, 16750, 16850, 16950, 16954)

* baud_base set base baud rate (CLOCK_FREQ / 16)

What i did was that i kept on changing my UART and kept the baud_base as 230400. When I changed my UART to 16550A. And i got connected to the internet running wvdial Reliance

[Fyi: I am sending this information using ZTE MC315 CDMA 1X Reliance connected on OS FC5.]

Dear Reddy,

I tried again, now I have changed the baud rate in wvdial.conf. Now after doing wvdial Reliance, I get the following message

Quote

--> WvDial: Internet dialer version 1.56

--> Initializing modem.

--> Sending: ATZ

--> Sending: ATQ0

--> Re-Sending: ATZ

--> Modem not responding.

Unquote

Requesting your help,

Regards,

Pushkaraj Apte

Pune

Share this post


Link to post
Share on other sites
Following commands are not working in my machine

* set UART type (none, 8250, 16450, 16550, 16550A,16650, 16650V2, 16750, 16850, 16950, 16954)

16650, 16650V2, 16750, 16850, 16950, 16954)

bash: syntax error near unexpected token `('

* baud_base set base baud rate (CLOCK_FREQ / 16)

bash: syntax error near unexpected token `('

that's not the proper command. the text you entered was from the help of the setserial command.

You need to enter the commands like this:

setserial /dev/ttyS3 uart XXXXX

where XXXXX is replaced by the UART values, which can be one of the following choices: none, 8250, 16450, 16550, 16550A,16650, 16650V2, 16750, 16850, 16950 and 16954.

Similarly, "* baud_base set base baud rate (CLOCK_FREQ / 16)" is not a command, but a description of what the arguments for setserial's baud_base setting can be. The actual command that people have had success with is:

setserial /dev/ttyS3 baud_base 230400

Here, remember that it might not be ttyS3 for you, you need to find out which tty was activated and therefore, which one you have to use by doing

dmesg | grep tty

just after plugging the card in.

Cheers

Share this post


Link to post
Share on other sites

setserial /dev/ttyS3 uart XXXXX

XXXXX - 16550A,16650, 16650V2, 16750, 16850, 16950 and 16954.

and kept the baud_base 230400 for each try

setserial /dev/ttyS3 baud_base 230400

I changed the set serial and the baud rate. Even after tried wvdial several times, I can't connect to internet from ubuntu.

--> WvDial: Internet dialer version 1.56

--> Initializing modem.

--> Sending: ATZ

--> Sending: ATQ0

--> Re-Sending: ATZ

--> Modem not responding.

Share this post


Link to post
Share on other sites

I followed the steps mentioned here but cant get zte to work on Fedora 7. Infact wvdialconf is not able to detect any modem on my system.

Does this solution work without wvdialconf being able to detect modem, or shall i first try to get wvdialconf to detect the modem and then try to do anything else.

Any suggestions?

Cheers,

Ashutosh

Share this post


Link to post
Share on other sites

Hi All,

I am using Ubuntu 7.10. Just installed it.

tried everything mentioned in this forum. but get modem not responding.

Quote

--> WvDial: Internet dialer version 1.56

--> Initializing modem.

--> Sending: ATZ

--> Sending: ATQ0

--> Re-Sending: ATZ

--> Modem not responding.

Unquote

Share this post


Link to post
Share on other sites

Now Surf the internet on Zte mc315 datacard on Reliance.

Solution to your ZTE PCMCIA CARD Connection PROBLEMS

Iam able to connect after loosing one night sleep and doing some experiements.

to have ZTE card working try the following steps.

open terminal and first of all run

dmesg

for getting card info you can also use

pccardctl info

but use dmesg

it should be able to show you following output if your ZTE is detected.

pccard: PCMCIA card inserted into slot 0 
[   17.688000] cs: memory probe 0xb0100000-0xb01fffff: excluding 0xb0100000-0xb010ffff
[   17.692000] pcmcia: registering new device pcmcia0.0
[   17.712000] tifm_core: MMC/SD card detected in socket 0:3
[   17.744000] cs: IO port probe 0x100-0x3af: clean.
[   17.748000] cs: IO port probe 0x3e0-0x4ff: excluding 0x4d0-0x4d7
[   17.748000] cs: IO port probe 0x820-0x8ff: clean.
[   17.748000] cs: IO port probe 0xc00-0xcf7: clean. 
[   17.748000] cs: IO port probe 0xa00-0xaff: clean.
[   17.876000] ttyS3: detected caps 00000700 should be 00000100
[   17.876000] 0.0: ttyS3 at I/O 0x2e8 (irq = 3) is a 16C950/954

this shows there's a device pcmcia ttyS3 (irq = 3)

we'll now setserial for this device by command.

sudo setserial /dev/ttyS3 baud_base 230400

{note baud_base may be different on differnt versions of card, but on my currenlty only 230400 is working, i'll expieriment more soon}

now edit your wvdial.conf, this needs to be done as super user.

sudo pico /etc/wvdial.conf

if your pcmcia card is detected as ttyS3 you can copy the code from below text

[Dialer Defaults]

Modem = /dev/ttyS3

Baud = 57600

Setvolume = 0

Dial-AT-OK ATDT Command =

Init1 = ATZ

FlowControl = Hardware (CRTSCTS)

Phone = #777

Username = 933xxxxxx

Password = 933xxxxxx

New PPPD = yes

Carrier Check = no

Stupid Mode = yes

Make sure you use stupid mode = yes instead of numeric value.

save and exit from pico.

now you are close to success,

run

sudo wvdial

the modem should be responding by now and you should be able to see some handshaking text along with your DNS servers and local IP.

sample output should be like :-

$ [color="#FF0000"]sudo wvdial[/color]
WvDial<*1>: WvDial: Internet dialer version 1.56
WvDial<*1>: Initializing modem.
WvDial<*1>: Sending: ATZ
WvDial Modem<*1>: ATZ 
WvDial Modem<*1>: OK
WvDial<*1>: Modem initialized.
WvDial<*1>: Sending: ATDT#777
WvDial<*1>: Waiting for carrier.
WvDial Modem<*1>: ATDT#777
WvDial Modem<*1>: CONNECT 
WvDial<*1>: Carrier detected.  Starting PPP immediately.
WvDial<Notice>: Starting pppd at Thu Jan 10 01:45:21 2008
WvDial<Notice>: Pid of pppd: 7883
WvDial<*1>: Using interface ppp0
WvDial<*1>: pppd:  �[06][08]��[06][08]
WvDial<*1>: pppd:  �[06][08]��[06][08]
WvDial<*1>: pppd:  �[06][08]��[06][08]
WvDial<*1>: pppd:  �[06][08]��[06][08]
WvDial<*1>: local  IP address 220.226.x.1xx
WvDial<*1>: pppd:  �[06][08]��[06][08]
WvDial<*1>: remote IP address 220.224.1xx.x
WvDial<*1>: pppd:  �[06][08]��[06][08]
WvDial<*1>: primary   DNS address 202.138.Xxx.xxx 
WvDial<*1>: pppd:  �[06][08]��[06][08]
WvDial<*1>: secondary DNS address 202.138.Xx.x
WvDial<*1>: pppd:  �[06][08]��[06][08]

if you see the DNS servers its time to save it to your resolv.conf file.

ctrl + C will exit the Wvdial.

sudo pico /etc/resolv.conf

and just put 2 lines as

nameserver 202.138.10x.1xx

nameserver 202.138.9x.x

save and exit ( above values may be different based on your ISP settings)

just run

$ sudo wvdial

if all above was done correctly you should open firefox and do some testing.

Enjoy net using ZTE MC 315

here's my speed test

220345827.png

EDITED AGAIN as iam getting 132kbps now after re-connecting

I mostly get 120kbps during nights and off peaks hours.

anyway if anybody not able to get it working yet, let me know I'll check if i missed any tricks.

thanks,

pk

Edited by pkgh

Share this post


Link to post
Share on other sites

Hi,

I did above all steps.Finally it is working for me after six months.It connects to net some time. Some times it is not connecting.

I also did dmesg >sample.txt

When I looked into sample.txt it shows kill switch is turned on.

If kill switch is turned on, wvdial says modem is not responding.

Can you help me how to turn off kill switch?

[ 17.380000] NTFS volume version 3.1.

[ 17.716000] ipw3945: Radio Frequency Kill Switch is On:

[ 17.716000] Kill switch must be turned off for wireless networking to work.

[ 22.376000] PPP generic driver version 2.4.2

[ 22.416000] NET: Registered protocol family 10

OS - UBUNTU Feisfy Fawn 7.04

Laptop model- Acer 5583

Regards,

Siva.

Edited by sivaraj005

Share this post


Link to post
Share on other sites

I checked one similar card ZTE MC315+ supplied by Reliance on Puppy Linux and Fedora 8 Live CD by the above procedure.

I could connect without changing the uart and changing only baud_base to 460800

setserial /dev/ttyS3 baud_base 460800

The original uart value was 16950/954 which works.

If I change the uart to 16550A keeping same baud_base (460800) it also works.

Although Ubuntu fan I did not check with Ubuntu Live CD because it does not have setserial and the person for whom I checked wanted to use Fedora 8.

kagashe

Share this post


Link to post
Share on other sites

Hi I am Shafi,, REGARDS

Iam Very Happy To Join In Linux Globe

my Qustion is How to config ZTE MC315 on laptop

how to crate wvdial config file

Please explain prefely

Shafi

Share this post


Link to post
Share on other sites

Hi Finally internet is connecting from UBUNTU Feisty Fawn 7.04 using RELIANCE ZTE PCMCA card.

Following are the command I tried.

Thanks for the group for providing the help.

setserial -g /dev/ttyS*

setserial -ga /dev/ttyS*

setserial /dev/ttyS3 uart 16750

setserial /dev/ttyS3 baud_base 230400

wvdial Reliance

or

setserial /dev/ttyS3 uart 16550A

setserial /dev/ttyS3 baud_base 460800

wvdial Reliance

Thanks

Sivaraj.v

Share this post


Link to post
Share on other sites

My name is Sujit. Running redhat5. After Connecction when I am trying to accee the url via Firefox, it says

Server not found

Firefox can't find the server at www.google.com.

* Check the address for typing errors such as

ww.example.com instead of

www.example.com

* If you are unable to load any pages, check your computer's network

connection.

* If your computer or network is protected by a firewall or proxy, make sure

that Firefox is permitted to access the Web.

No idea whats going on ?

Thnx,

-Sujit

Share this post


Link to post
Share on other sites

Thnaks to all .

Finally I've shoutout the problem. Just edited the two servers at:

vi /etc/resolv.conf

nameserver xxxxxxxxxxxxxxx

nameserver xxxxxxxxxxxxxxx

:wq

It is working now.: )

Bye

Share this post


Link to post
Share on other sites

Hi,

I have a reliance MC 315+ PCMCIA card that works on my windows machine. I have been trying to set it up on my Ubuntu 7.10 using wvdial/pppd. I managed to get it to connect to reliance server (uart 16650V2, baud_base 460800). However, the LCP part of setup fails with the following in my /var/log/messages:

Aug 1 15:51:34 arvind pppd[25861]: pppd 2.4.4 started by root, uid 0

Aug 1 15:51:35 arvind chat[25863]: send (at+crm=1^M)

Aug 1 15:51:35 arvind chat[25863]: expect (OK)

Aug 1 15:51:35 arvind chat[25863]: at+crm=1^M^M

Aug 1 15:51:35 arvind chat[25863]: OK

Aug 1 15:51:35 arvind chat[25863]: -- got it

Aug 1 15:51:35 arvind chat[25863]: send (atdt#777^M)

Aug 1 15:51:35 arvind chat[25863]: expect (CONNECT)

Aug 1 15:51:35 arvind chat[25863]: ^M

Aug 1 15:51:35 arvind chat[25863]: atdt#777^M^M

Aug 1 15:51:35 arvind chat[25863]: CONNECT

Aug 1 15:51:35 arvind chat[25863]: -- got it

Aug 1 15:51:35 arvind pppd[25861]: Serial connection established.

Aug 1 15:51:35 arvind pppd[25861]: Using interface ppp0

Aug 1 15:51:35 arvind pppd[25861]: Connect: ppp0 <--> /dev/ttyS3

Aug 1 15:52:06 arvind pppd[25861]: LCP: timeout sending Config-Requests

Aug 1 15:52:06 arvind pppd[25861]: Connection terminated.

Aug 1 15:52:06 arvind pppd[25861]: Hangup (SIGHUP)

Aug 1 15:52:06 arvind pppd[25861]: Modem hangup

Aug 1 15:52:06 arvind pppd[25861]: Exit.

Here is the wvdial responose part, which seems fine till it not getting the IPs:

WvDial<*1>: WvDial: Internet dialer version 1.56

WvDial<*1>: Initializing modem.

WvDial<*1>: Sending: ATZ

WvDial Modem<*1>: ATZ

WvDial Modem<*1>: OK

WvDial<*1>: Modem initialized.

WvDial<*1>: Sending: ATDT#777

WvDial<*1>: Waiting for carrier.

WvDial Modem<*1>: ATDT#777

WvDial Modem<*1>: CONNECT

WvDial<*1>: Carrier detected. Starting PPP immediately.

WvDial<Notice>: Starting pppd at Fri Aug 1 17:09:52 2008

WvDial<Notice>: Pid of pppd: 26325

WvDial<*1>: pppd: ȗ[06][08]��[06][08]

WvDial<*1>: Using interface ppp0

WvDial<*1>: pppd: ȗ[06][08]��[06][08]

WvDial<*1>: pppd: ȗ[06][08]��[06][08]

WvDial<*1>: pppd: ȗ[06][08]��[06][08]

WvDial<*1>: pppd: ȗ[06][08]��[06][08]

Any idea what might be the problem, and how can I fix it?

Thanks,

Arvind

Share this post


Link to post
Share on other sites

You can try these steps: Reliance data card:

Step1

Connect card to the laptop/pc via USB or serial Cable.

check this cmd

#wvdialconf /etc/wvdial.conf

If everything is alright, a usb modem configuration is written to

/etc/wvdial.conf. You need to edit as per your card's info

Step2

edit the file as follows:

#vi /etc/wvdial.conf

Modify the file as follows:

[Dialer Defaults]

Modem=/dev/ttyACM0 -- >Set it accordingly

Baud=115200

Dial Command = ATDT

init1=ATZ

init2=AT+CRM=1

ISDN = 0

Modem Type = USB Modem

Flow Control= Hardware (CRTSCTS)

Username = your data card's phone #

Password = respective password

Phone = #777

Stupid Mode = 1

:wq! exit

Step3

#wvdial

If connected, you'll see the ip of yr system,

primary& secondary dns servers.

U can disconnect by pressing ctrl +c

Step4

if it ic onnected but u are not able to open the web page, you may need to edit dns ips to /etc/resolv.conf file

nameserver [ip of primary dns server]

nameserver [ip of secondary dns server]

The run again.

#wvdial

If at any point of time you find the steps difficult to understand, please reply back.

-Suit

Hi I am Shafi,, REGARDS

Iam Very Happy To Join In Linux Globe

my Qustion is How to config ZTE MC315 on laptop

how to crate wvdial config file

Please explain prefely

Shafi

Share this post


Link to post
Share on other sites

Hi,

It is showing me connected but I'm not able to surf any website. Pls help.

Below is the log

--> WvDial: Internet dialer version 1.60

--> Initializing modem.

--> Sending: ATZ

ATZ

OK

--> Modem initialized.

--> Sending: ATDT#777

--> Waiting for carrier.

ATDT#777

CONNECT

--> Carrier detected. Starting PPP immediately.

--> Starting pppd at Wed Jun 10 14:11:31 2009

--> Pid of pppd: 5453

--> Using interface ppp0

--> pppd: [10][06]

--> [08]

--> pppd: [10][06]

--> [08]

--> pppd: [10][06]

--> [08]

--> pppd: [10][06]

--> [08]

--> pppd: [10][06]

--> [08]

--> local IP address 115.240.174.248

--> pppd: [10][06]

--> [08]

--> remote IP address 220.224.141.129

--> pppd: [10][06]

--> [08]

--> primary DNS address 202.138.97.193

--> pppd: [10][06]

--> [08]

--> secondary DNS address 202.138.96.2

--> pppd: [10][06]

--> [08]

--> pppd: [10][06]

--> [08]

--> pppd: [10][06]

--> [08]

Share this post


Link to post
Share on other sites

Thanks so much for all the info!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now