Jungle Boy

Reliance Netconnect Usb Card On Linux - Howto

31 posts in this topic

Reliance Netconnect USB card on Linux - Howto

=============================================

The following worked for me on Ubuntu amd64 but should work

for all the distros.

Execute everything as root

Check your card is recognized by the kernel

Code:

# cat /proc/bus/usb/devices

.....

.....

T: Bus=02 Lev=01 Prnt=01 Port=05 Cnt=02 Dev#= 4 Spd=12 MxCh= 0

D: Ver= 1.01 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=16 #Cfgs= 1

P: Vendor=12d1 ProdID=1001 Rev= 0.00

S: Manufacturer=Huawei Technologies

S: Product=Huawei Mobile

S: SerialNumber=HUAWEI EC3X1

C:* #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA

I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=pl2303

E: Ad=81(I) Atr=03(Int.) MxPS= 16 Ivl=128ms

E: Ad=8a(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

E: Ad=0b(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=pl2303

E: Ad=83(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

E: Ad=06(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

.....

.....

Now modprobe the driver

Code:

# modprobe usbserial vendor=0x12d1 product=0x1001

Should get something like this with dmesg

Code:

# dmesg

[ 2315.412106] usbcore: registered new interface driver usbserial

[ 2315.412508] drivers/usb/serial/usb-serial.c: USB Serial support registered for generic

[ 2315.461938] usbcore: registered new interface driver usbserial_generic

[ 2315.461945] drivers/usb/serial/usb-serial.c: USB Serial Driver core

[ 2315.480382] drivers/usb/serial/usb-serial.c: USB Serial support registered for pl2303

[ 2315.480414] pl2303 2-6:1.0: pl2303 converter detected

[ 2315.480608] usb 2-6: pl2303 converter now attached to ttyUSB0

[ 2315.480620] pl2303 2-6:1.1: pl2303 converter detected

[ 2315.480691] usb 2-6: pl2303 converter now attached to ttyUSB1

Now edit your wvdial.conf file

Code

# vi /etc/wvdial.conf

[Modem0]

Modem = /dev/ttyUSB0

Baud = 115200

SetVolume = 0

Dial Command = ATDT

Init1 = ATZ

FlowControl = Hardware (CRTSCTS)

[Dialer cdma]

Username = You Phone Number Here

Password = Your Password ... usually same as your phone number

Phone = #777

Stupid Mode = 1

Inherits = Modem0

Now run wvdial

Code:

# wvdial cdma

--> WvDial: Internet dialer version 1.56

--> Cannot get information for serial port.

--> Initializing modem.

--> Sending: ATZ

ATZ

OK

--> Modem initialized.

--> Sending: ATDT#777

--> Waiting for carrier.

ATDT#777

CONNECT 230400

--> Carrier detected. Starting PPP immediately.

--> Starting pppd at Sat Mar 3 22:55:20 2007

--> Pid of pppd: 24314

--> Using interface ppp0

--> local IP address 220.226.50.126

--> remote IP address 97.239.2.10

--> primary DNS address 202.138.103.100

--> secondary DNS address 202.138.96.2

Thats it ... you are now connected

Ensure that your internet traffic goes through your "Modem"

In Ubuntu ... this can be done @ System->Administration->Networking

Enjoy :o)

Dunno how to make this sticky ... if anyone can, please do it

1 person likes this

Share this post


Link to post
Share on other sites
Dunno how to make this sticky ... if anyone can, please do it

Done ! Thanks for sharing your findings !

Share this post


Link to post
Share on other sites
Dunno how to make this sticky ... if anyone can, please do it

Done ! Thanks for sharing your findings !

hello sir,

can u please help me out with the driver for huawei ec325 for macbook....i cannot connect to net using dis card can u suggest me any way to do dis ...plzzz help me out

Share this post


Link to post
Share on other sites

I am not much aware of MacOS . I think it uses a BSD kernel. Google "EC325 BSD" and you may land up with something.

If your MAC is a new one, it would be using a intel processor. You can always install windows and your card would work fine. Else follow the steps below with http://mirror.in.th/ubuntu/edgy/ubuntu-6.10-desktop-i386.iso

If its an old PowerPC based MAC, you can use

http://mirror.in.th/ubuntu/edgy/ubuntu-6.1...top-powerpc.iso

Ubuntu is one of the flavours of Linux Operating System. the above images are live discs - that is you can boot into this system without having to install on your hard disk. Just download it (Sorry for the catch 22 here ;o)) and burn it on a CD and boot using the CD ... and follow the steps in first post ... your card should work fine.

A live disc is very slow and the above step would only be useful for surfing. Moreover, until you know how to access your hard disk, you wont be able to download and store anything permanently. Well, you can always install it on ur system once you get comfortable with it.

Sorry for all the techie jargon. In case you do not understand something, feel free to ask

Share this post


Link to post
Share on other sites

It worked GREAT in Ubundu... I couldnt find Modem = /dev/ttyUSB0 ... Help in finding an exact modem in Centos(RedHat Distors)

Share this post


Link to post
Share on other sites

Hello frnds,

4-5 days before I bought a HUAWEI EC 325 Card.. and i need to connect to web through this netconnect usb card... I have installed the software in winxp[32-bit] and its running cool... but in the other hand i have installed redhat enterprise linux 4.0 and i want to know that how i can connect to web via this usb card... the web world guys told me that u cant connct to web in linux through this usb card... so i am very very sad now :grin::( ... what i will do now... is the above process can solve my prob?? btw what is the command to disconnect frm net ... Jungle guy didnt mention the command to disconnect frm net.. can u plz share that command... and plz tell me what procedure i should follow to install net in lnx enterprise plz..

waiting

Share this post


Link to post
Share on other sites
Reliance Netconnect USB card on Linux - Howto

=============================================

The following worked for me on Ubuntu amd64 but should work

for all the distros.

Execute everything as root

Check your card is recognized by the kernel

Code:

# cat /proc/bus/usb/devices

.....

.....

T: Bus=02 Lev=01 Prnt=01 Port=05 Cnt=02 Dev#= 4 Spd=12 MxCh= 0

D: Ver= 1.01 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=16 #Cfgs= 1

P: Vendor=12d1 ProdID=1001 Rev= 0.00

S: Manufacturer=Huawei Technologies

S: Product=Huawei Mobile

S: SerialNumber=HUAWEI EC3X1

C:* #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA

I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=pl2303

E: Ad=81(I) Atr=03(Int.) MxPS= 16 Ivl=128ms

E: Ad=8a(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

E: Ad=0b(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=pl2303

E: Ad=83(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

E: Ad=06(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

.....

.....

Now modprobe the driver

Code:

# modprobe usbserial vendor=0x12d1 product=0x1001

Should get something like this with dmesg

Code:

# dmesg

[ 2315.412106] usbcore: registered new interface driver usbserial

[ 2315.412508] drivers/usb/serial/usb-serial.c: USB Serial support registered for generic

[ 2315.461938] usbcore: registered new interface driver usbserial_generic

[ 2315.461945] drivers/usb/serial/usb-serial.c: USB Serial Driver core

[ 2315.480382] drivers/usb/serial/usb-serial.c: USB Serial support registered for pl2303

[ 2315.480414] pl2303 2-6:1.0: pl2303 converter detected

[ 2315.480608] usb 2-6: pl2303 converter now attached to ttyUSB0

[ 2315.480620] pl2303 2-6:1.1: pl2303 converter detected

[ 2315.480691] usb 2-6: pl2303 converter now attached to ttyUSB1

Now edit your wvdial.conf file

Code

# vi /etc/wvdial.conf

[Modem0]

Modem = /dev/ttyUSB0

Baud = 115200

SetVolume = 0

Dial Command = ATDT

Init1 = ATZ

FlowControl = Hardware (CRTSCTS)

[Dialer cdma]

Username = You Phone Number Here

Password = Your Password ... usually same as your phone number

Phone = #777

Stupid Mode = 1

Inherits = Modem0

Now run wvdial

Code:

# wvdial cdma

--> WvDial: Internet dialer version 1.56

--> Cannot get information for serial port.

--> Initializing modem.

--> Sending: ATZ

ATZ

OK

--> Modem initialized.

--> Sending: ATDT#777

--> Waiting for carrier.

ATDT#777

CONNECT 230400

--> Carrier detected. Starting PPP immediately.

--> Starting pppd at Sat Mar 3 22:55:20 2007

--> Pid of pppd: 24314

--> Using interface ppp0

--> local IP address 220.226.50.126

--> remote IP address 97.239.2.10

--> primary DNS address 202.138.103.100

--> secondary DNS address 202.138.96.2

Thats it ... you are now connected

Ensure that your internet traffic goes through your "Modem"

In Ubuntu ... this can be done @ System->Administration->Networking

Enjoy :) )

Dunno how to make this sticky ... if anyone can, please do it

Hi,

I've done as have mentioned above and everything is fine.

But i'm unable to connect to net.

Do i need to any ethernet driver for wireless, as i did not see any driver installed in my system.

(i dont have driver instlled for ethernet driver. )

Share this post


Link to post
Share on other sites

I think you are not able to connect because your your network traffic is being connected through your other ethernet devices and not your modem. You need to disable all the other network devices so that your internet traffic is routed through your modem :) . You can see your network devices through

$ ifconfig

They are generally named eth*

to disable your devices, just execute

$ ifdown eth0

to disable eth0

The above worked for me. My networking knowledge is on the weaker side. So am not sure if it would work for everyone.

@ravikumarv:

You won't be able to see your modem through "ifconfig" until you connect using "wvdial". In case you need help, please copy/paste the output of atleast "wvdial". Just saying "It Ain't Working" isn't gonna be very helpful :)

Share this post


Link to post
Share on other sites

I use a USB, HuaweiEC325 reliance netconnect modem on ubuntu :lol: . The settings mentoned above worked for me :GirandoOjos: , but for one slight problem. I cant surf webpages ;) . Chat via GAIM works, email and pop3 via thunderbird works, DNS works, except for the web pages. The only pages i can open are www.export.gov, www.trade.gov, and a few others (mostly .gov). I find this weird. Anyone have a clue about what the problem is? I also checked whether i can reach to websites by telnetting to port 80 of websites, I can. The firewall is down, so that is not the issue. any pointers? Eth0 and other unrelated interfaces have also been disabled, the route is set fine, the gateways are okay, i can ping anyplace i want. Just the damn webpages won't come through. :NOTriste:

What is the new netbooster thing being setup on netconnect? I know it's a squid proxy+dns cache for windows, any other settings I need to know? Is it the problem?

Help! ;)

Share this post


Link to post
Share on other sites

Today I bought a Reliance ZTE CDMA Data Modem (MG880) and this these steps worked fine on my SLED 10 SP1 desktop.. Thanks for a nice tutorial.

Share this post


Link to post
Share on other sites

hi to all

i have a problem

i done all the steps as mentioned above i connected to internet but i still unable to browse the web.

i m using the FEDORA CORE 7

please help me to solve this problem

Share this post


Link to post
Share on other sites
Reliance Netconnect USB card on Linux - Howto

=============================================

The following worked for me on Ubuntu amd64 but should work

for all the distros.

Execute everything as root

Check your card is recognized by the kernel

Code:

# cat /proc/bus/usb/devices

.....

.....

T: Bus=02 Lev=01 Prnt=01 Port=05 Cnt=02 Dev#= 4 Spd=12 MxCh= 0

D: Ver= 1.01 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=16 #Cfgs= 1

P: Vendor=12d1 ProdID=1001 Rev= 0.00

S: Manufacturer=Huawei Technologies

S: Product=Huawei Mobile

S: SerialNumber=HUAWEI EC3X1

C:* #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA

I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=pl2303

E: Ad=81(I) Atr=03(Int.) MxPS= 16 Ivl=128ms

E: Ad=8a(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

E: Ad=0b(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=pl2303

E: Ad=83(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

E: Ad=06(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

.....

.....

Now modprobe the driver

Code:

# modprobe usbserial vendor=0x12d1 product=0x1001

Should get something like this with dmesg

Code:

# dmesg

[ 2315.412106] usbcore: registered new interface driver usbserial

[ 2315.412508] drivers/usb/serial/usb-serial.c: USB Serial support registered for generic

[ 2315.461938] usbcore: registered new interface driver usbserial_generic

[ 2315.461945] drivers/usb/serial/usb-serial.c: USB Serial Driver core

[ 2315.480382] drivers/usb/serial/usb-serial.c: USB Serial support registered for pl2303

[ 2315.480414] pl2303 2-6:1.0: pl2303 converter detected

[ 2315.480608] usb 2-6: pl2303 converter now attached to ttyUSB0

[ 2315.480620] pl2303 2-6:1.1: pl2303 converter detected

[ 2315.480691] usb 2-6: pl2303 converter now attached to ttyUSB1

Now edit your wvdial.conf file

Code

# vi /etc/wvdial.conf

[Modem0]

Modem = /dev/ttyUSB0

Baud = 115200

SetVolume = 0

Dial Command = ATDT

Init1 = ATZ

FlowControl = Hardware (CRTSCTS)

[Dialer cdma]

Username = You Phone Number Here

Password = Your Password ... usually same as your phone number

Phone = #777

Stupid Mode = 1

Inherits = Modem0

Now run wvdial

Code:

# wvdial cdma

--> WvDial: Internet dialer version 1.56

--> Cannot get information for serial port.

--> Initializing modem.

--> Sending: ATZ

ATZ

OK

--> Modem initialized.

--> Sending: ATDT#777

--> Waiting for carrier.

ATDT#777

CONNECT 230400

--> Carrier detected. Starting PPP immediately.

--> Starting pppd at Sat Mar 3 22:55:20 2007

--> Pid of pppd: 24314

--> Using interface ppp0

--> local IP address 220.226.50.126

--> remote IP address 97.239.2.10

--> primary DNS address 202.138.103.100

--> secondary DNS address 202.138.96.2

Thats it ... you are now connected

Ensure that your internet traffic goes through your "Modem"

In Ubuntu ... this can be done @ System->Administration->Networking

Enjoy :o )

Dunno how to make this sticky ... if anyone can, please do it

Hi Guys,

I m running Slackware Linxu 11.0, Netconnect modem is recognized at usb port, writen wvdial.conf file, but i do'nt find wvdial in my distro.

can you please help me out wheredo i find wvdial app.

Thanks

Arun Kumar

Share this post


Link to post
Share on other sites
Hello frnds,

4-5 days before I bought a HUAWEI EC 325 Card.. and i need to connect to web through this netconnect usb card... I have installed the software in winxp[32-bit] and its running cool... but in the other hand i have installed redhat enterprise linux 4.0 and i want to know that how i can connect to web via this usb card... the web world guys told me that u cant connct to web in linux through this usb card... so i am very very sad now :(:( ... what i will do now... is the above process can solve my prob?? btw what is the command to disconnect frm net ... Jungle guy didnt mention the command to disconnect frm net.. can u plz share that command... and plz tell me what procedure i should follow to install net in lnx enterprise plz..

waiting

To disconnect press Ctrl+C on the same terminal from where the wvdial cmd is executed :winko:

Share this post


Link to post
Share on other sites
hi to all

i have a problem

i done all the steps as mentioned above i connected to internet but i still unable to browse the web.

i m using the FEDORA CORE 7

please help me to solve this problem

Hi... I also had the same problem.... The alternative solution is to use KPPP. It works fine with this. You have to configure KPPP with the same parameters as that of /etc/wvdial.conf :GirandoOjos:

Share this post


Link to post
Share on other sites
Reliance Netconnect USB card on Linux - Howto

=============================================

The following worked for me on Ubuntu amd64 but should work

for all the distros.

Execute everything as root

Check your card is recognized by the kernel

Code:

# cat /proc/bus/usb/devices

.....

.....

T: Bus=02 Lev=01 Prnt=01 Port=05 Cnt=02 Dev#= 4 Spd=12 MxCh= 0

D: Ver= 1.01 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=16 #Cfgs= 1

P: Vendor=12d1 ProdID=1001 Rev= 0.00

S: Manufacturer=Huawei Technologies

S: Product=Huawei Mobile

S: SerialNumber=HUAWEI EC3X1

C:* #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA

I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=pl2303

E: Ad=81(I) Atr=03(Int.) MxPS= 16 Ivl=128ms

E: Ad=8a(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

E: Ad=0b(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=pl2303

E: Ad=83(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

E: Ad=06(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

.....

.....

Now modprobe the driver

Code:

# modprobe usbserial vendor=0x12d1 product=0x1001

Should get something like this with dmesg

Code:

# dmesg

[ 2315.412106] usbcore: registered new interface driver usbserial

[ 2315.412508] drivers/usb/serial/usb-serial.c: USB Serial support registered for generic

[ 2315.461938] usbcore: registered new interface driver usbserial_generic

[ 2315.461945] drivers/usb/serial/usb-serial.c: USB Serial Driver core

[ 2315.480382] drivers/usb/serial/usb-serial.c: USB Serial support registered for pl2303

[ 2315.480414] pl2303 2-6:1.0: pl2303 converter detected

[ 2315.480608] usb 2-6: pl2303 converter now attached to ttyUSB0

[ 2315.480620] pl2303 2-6:1.1: pl2303 converter detected

[ 2315.480691] usb 2-6: pl2303 converter now attached to ttyUSB1

Now edit your wvdial.conf file

Code

# vi /etc/wvdial.conf

[Modem0]

Modem = /dev/ttyUSB0

Baud = 115200

SetVolume = 0

Dial Command = ATDT

Init1 = ATZ

FlowControl = Hardware (CRTSCTS)

[Dialer cdma]

Username = You Phone Number Here

Password = Your Password ... usually same as your phone number

Phone = #777

Stupid Mode = 1

Inherits = Modem0

Now run wvdial

Code:

# wvdial cdma

--> WvDial: Internet dialer version 1.56

--> Cannot get information for serial port.

--> Initializing modem.

--> Sending: ATZ

ATZ

OK

--> Modem initialized.

--> Sending: ATDT#777

--> Waiting for carrier.

ATDT#777

CONNECT 230400

--> Carrier detected. Starting PPP immediately.

--> Starting pppd at Sat Mar 3 22:55:20 2007

--> Pid of pppd: 24314

--> Using interface ppp0

--> local IP address 220.226.50.126

--> remote IP address 97.239.2.10

--> primary DNS address 202.138.103.100

--> secondary DNS address 202.138.96.2

Thats it ... you are now connected

Ensure that your internet traffic goes through your "Modem"

In Ubuntu ... this can be done @ System->Administration->Networking

Enjoy :o )

Dunno how to make this sticky ... if anyone can, please do it

hi

thanks...

do you know how to send sms programatically through Huawei Ec325 using at commands...

I tried in Hyper Terminal of windows but sms at comands are not working...

Share this post


Link to post
Share on other sites
Reliance Netconnect USB card on Linux - Howto

=============================================

The following worked for me on Ubuntu amd64 but should work

for all the distros.

Execute everything as root

Check your card is recognized by the kernel

Code:

# cat /proc/bus/usb/devices

.....

.....

T: Bus=02 Lev=01 Prnt=01 Port=05 Cnt=02 Dev#= 4 Spd=12 MxCh= 0

D: Ver= 1.01 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=16 #Cfgs= 1

P: Vendor=12d1 ProdID=1001 Rev= 0.00

S: Manufacturer=Huawei Technologies

S: Product=Huawei Mobile

S: SerialNumber=HUAWEI EC3X1

C:* #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA

I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=pl2303

E: Ad=81(I) Atr=03(Int.) MxPS= 16 Ivl=128ms

E: Ad=8a(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

E: Ad=0b(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=pl2303

E: Ad=83(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

E: Ad=06(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

.....

.....

Now modprobe the driver

Code:

# modprobe usbserial vendor=0x12d1 product=0x1001

Should get something like this with dmesg

Code:

# dmesg

[ 2315.412106] usbcore: registered new interface driver usbserial

[ 2315.412508] drivers/usb/serial/usb-serial.c: USB Serial support registered for generic

[ 2315.461938] usbcore: registered new interface driver usbserial_generic

[ 2315.461945] drivers/usb/serial/usb-serial.c: USB Serial Driver core

[ 2315.480382] drivers/usb/serial/usb-serial.c: USB Serial support registered for pl2303

[ 2315.480414] pl2303 2-6:1.0: pl2303 converter detected

[ 2315.480608] usb 2-6: pl2303 converter now attached to ttyUSB0

[ 2315.480620] pl2303 2-6:1.1: pl2303 converter detected

[ 2315.480691] usb 2-6: pl2303 converter now attached to ttyUSB1

Now edit your wvdial.conf file

Code

# vi /etc/wvdial.conf

[Modem0]

Modem = /dev/ttyUSB0

Baud = 115200

SetVolume = 0

Dial Command = ATDT

Init1 = ATZ

FlowControl = Hardware (CRTSCTS)

[Dialer cdma]

Username = You Phone Number Here

Password = Your Password ... usually same as your phone number

Phone = #777

Stupid Mode = 1

Inherits = Modem0

Now run wvdial

Code:

# wvdial cdma

--> WvDial: Internet dialer version 1.56

--> Cannot get information for serial port.

--> Initializing modem.

--> Sending: ATZ

ATZ

OK

--> Modem initialized.

--> Sending: ATDT#777

--> Waiting for carrier.

ATDT#777

CONNECT 230400

--> Carrier detected. Starting PPP immediately.

--> Starting pppd at Sat Mar 3 22:55:20 2007

--> Pid of pppd: 24314

--> Using interface ppp0

--> local IP address 220.226.50.126

--> remote IP address 97.239.2.10

--> primary DNS address 202.138.103.100

--> secondary DNS address 202.138.96.2

Thats it ... you are now connected

Ensure that your internet traffic goes through your "Modem"

In Ubuntu ... this can be done @ System->Administration->Networking

Enjoy :o )

Dunno how to make this sticky ... if anyone can, please do it

hi i am new to linux and using fedora 8 and would like to use the zte mg880 on it.

when the steps are followed i get the following....

[root@localhost ~]# wvdial zte

--> WvDial: Internet dialer version 1.60

--> Cannot get information for serial port.

--> Initializing modem.

--> Sending: ATZ

ATZ

OK

--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

OK

--> Modem initialized.

--> Sending: ATDT#777

--> Waiting for carrier.

ATDT#777

CONNECT

--> Carrier detected. Starting PPP immediately.

--> Starting pppd at Sat Mar 5 18:20:25 2008

--> Pid of pppd: 2864

--> Using interface ppp0

--> pppd: O�[08]@O�[08]

--> pppd: O�[08]@O�[08]

--> pppd: O�[08]@O�[08]

--> local IP address 220.226.16.2

--> pppd: O�[08]@O�[08]

--> remote IP address 220.224.135.36

--> pppd: O�[08]@O�[08]

--> primary DNS address 202.138.103.100

--> pppd: O�[08]@O�[08]

--> secondary DNS address 202.138.96.2

--> pppd: O�[08]@O�[08]

it stops with tis and when i use any browser it says cannot display page.

i dont know wat error this is.

pls help me.

Share this post


Link to post
Share on other sites
Reliance Netconnect USB card on Linux - Howto

=============================================

do it

hi

thanks...

do you know how to send sms programatically through Huawei Ec325 using at commands...

I tried in Hyper Terminal of windows but sms at comands are not working...

To send a sms using a reliance (huawei) usb modem you need to give the following command in a terminal like hyperterm in windows or minicom in linux.

AT$HSMSSD=<destID>, <length>, [ack], [format]<CR>

<msg>

in simple words

AT$HSMSSD=phone-number,length-of-message,ack,format

message

e.g. if you want to send the message "hello world" to phone number "12345678" and you dont need and acknowledgement and the format is ascii the command would be

AT$HSMSSD=12345678,11,0,1<CR>

hello world

the second parameter is 11 because there are 11 characters in the message.

You can write a simple script in linux to get this working.

Here is the direct translation of the chinese text

DestID: Reception Short Message Terminal numbers, ranges from 0 to 9, *, #, the effective length of 32;

Length: short message to be sent by the length of the English, the effective length of the range of 0 to 160 words

Festival For Chinese, effective length of the range of 0 to 70 Chinese characters;

Ack: that the need for the success of short messaging confirmed. 1 is a need to recognize; 0 no need for confirmation;

The parameters for optional, and if we do not enter this parameter, using AT $ HSMSSS choice of the Senate

Few.

Format: that the short message encoding formats; 1 for ASCII coding; 2 encoding for UNICODE, this

Parameters for optional, and if we do not enter this parameter, using AT $ HSMSSS choice of parameters.

Msg: information specific content.

Have fun

-Ashwin

www.petroniatech.com

Share this post


Link to post
Share on other sites
Reliance Netconnect USB card on Linux - Howto

=============================================

The following worked for me on Ubuntu amd64 but should work

for all the distros.

Execute everything as root

Check your card is recognized by the kernel

Code:

# cat /proc/bus/usb/devices

.....

.....

T: Bus=02 Lev=01 Prnt=01 Port=05 Cnt=02 Dev#= 4 Spd=12 MxCh= 0

D: Ver= 1.01 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=16 #Cfgs= 1

P: Vendor=12d1 ProdID=1001 Rev= 0.00

S: Manufacturer=Huawei Technologies

S: Product=Huawei Mobile

S: SerialNumber=HUAWEI EC3X1

C:* #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA

I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=pl2303

E: Ad=81(I) Atr=03(Int.) MxPS= 16 Ivl=128ms

E: Ad=8a(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

E: Ad=0b(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=pl2303

E: Ad=83(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

E: Ad=06(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

.....

.....

Now modprobe the driver

Code:

# modprobe usbserial vendor=0x12d1 product=0x1001

Should get something like this with dmesg

Code:

# dmesg

[ 2315.412106] usbcore: registered new interface driver usbserial

[ 2315.412508] drivers/usb/serial/usb-serial.c: USB Serial support registered for generic

[ 2315.461938] usbcore: registered new interface driver usbserial_generic

[ 2315.461945] drivers/usb/serial/usb-serial.c: USB Serial Driver core

[ 2315.480382] drivers/usb/serial/usb-serial.c: USB Serial support registered for pl2303

[ 2315.480414] pl2303 2-6:1.0: pl2303 converter detected

[ 2315.480608] usb 2-6: pl2303 converter now attached to ttyUSB0

[ 2315.480620] pl2303 2-6:1.1: pl2303 converter detected

[ 2315.480691] usb 2-6: pl2303 converter now attached to ttyUSB1

Now edit your wvdial.conf file

Code

# vi /etc/wvdial.conf

[Modem0]

Modem = /dev/ttyUSB0

Baud = 115200

SetVolume = 0

Dial Command = ATDT

Init1 = ATZ

FlowControl = Hardware (CRTSCTS)

[Dialer cdma]

Username = You Phone Number Here

Password = Your Password ... usually same as your phone number

Phone = #777

Stupid Mode = 1

Inherits = Modem0

Now run wvdial

Code:

# wvdial cdma

--> WvDial: Internet dialer version 1.56

--> Cannot get information for serial port.

--> Initializing modem.

--> Sending: ATZ

ATZ

OK

--> Modem initialized.

--> Sending: ATDT#777

--> Waiting for carrier.

ATDT#777

CONNECT 230400

--> Carrier detected. Starting PPP immediately.

--> Starting pppd at Sat Mar 3 22:55:20 2007

--> Pid of pppd: 24314

--> Using interface ppp0

--> local IP address 220.226.50.126

--> remote IP address 97.239.2.10

--> primary DNS address 202.138.103.100

--> secondary DNS address 202.138.96.2

Thats it ... you are now connected

Ensure that your internet traffic goes through your "Modem"

In Ubuntu ... this can be done @ System->Administration->Networking

Enjoy :o )

Dunno how to make this sticky ... if anyone can, please do it

hi i am new to linux and using fedora 8 and would like to use the zte mg880 on it.

when the steps are followed i get the following....

[root@localhost ~]# wvdial zte

--> WvDial: Internet dialer version 1.60

--> Cannot get information for serial port.

--> Initializing modem.

--> Sending: ATZ

ATZ

OK

--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

OK

--> Modem initialized.

--> Sending: ATDT#777

--> Waiting for carrier.

ATDT#777

CONNECT

--> Carrier detected. Starting PPP immediately.

--> Starting pppd at Sat Mar 5 18:20:25 2008

--> Pid of pppd: 2864

--> Using interface ppp0

--> pppd: O�[08]@O�[08]

--> pppd: O�[08]@O�[08]

--> pppd: O�[08]@O�[08]

--> local IP address 220.226.16.2

--> pppd: O�[08]@O�[08]

--> remote IP address 220.224.135.36

--> pppd: O�[08]@O�[08]

--> primary DNS address 202.138.103.100

--> pppd: O�[08]@O�[08]

--> secondary DNS address 202.138.96.2

--> pppd: O�[08]@O�[08]

it stops with tis and when i use any browser it says cannot display page.

i dont know wat error this is.

pls help me.

==============================

==============================

Hello,

Myself Sujit. I am running redhat5 and the connection is fine via usb-mg880-modem as:

[root@localhost ~]# wvdial

--> WvDial: Internet dialer version 1.54.0

--> Cannot get information for serial port.

--> Initializing modem.

--> Sending: ATZ

ATZ

OK

--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

OK

--> Modem initialized.

--> Sending: ATDT#777

--> Waiting for carrier.

ATDT#777

CONNECT

--> Carrier detected. Starting PPP immediately.

--> Starting pppd at Thu Apr 3 23:28:04 2008

--> pid of pppd: 4888

--> Using interface ppp0

--> pppd: Modem

--> pppd: Modem

--> pppd: Modem

--> local IP address 220.226.90.77

--> pppd: Modem

--> remote IP address 220.224.135.108

--> pppd: Modem

--> primary DNS address 202.138.103.100

--> pppd: Modem

--> secondary DNS address 202.138.96.2

--> pppd: Modem

BUT, when I try to open the Firefox following messages are encountered.. .......

Any idea?

+++++++++++++++++++++++++++++++++++++++++

Server not found

Firefox can't find the server at www.google.com.

* Check the address for typing errors such as

ww.example.com instead of

www.example.com

* If you are unable to load any pages, check your computer's network

connection.

* If your computer or network is protected by a firewall or proxy, make sure

that Firefox is permitted to access the Web.

+++++++++++++++++++++++++++++++++++++++++++++++++++++

Plz help me ..........

-Sujit

Share this post


Link to post
Share on other sites

I am still getting the same message in firefox browser :(

"Firefox can't find the server at www.yahoo.com"

Is there any setting I need to do ?

-Sujit

Share this post


Link to post
Share on other sites

Just added two servers at resolv.conf and its working now.

thanks to all.

Share this post


Link to post
Share on other sites
Reliance Netconnect USB card on Linux - Howto

=============================================

The following worked for me on Ubuntu amd64 but should work

for all the distros.

Execute everything as root

Check your card is recognized by the kernel

Code:

# cat /proc/bus/usb/devices

.....

.....

T: Bus=02 Lev=01 Prnt=01 Port=05 Cnt=02 Dev#= 4 Spd=12 MxCh= 0

D: Ver= 1.01 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=16 #Cfgs= 1

P: Vendor=12d1 ProdID=1001 Rev= 0.00

S: Manufacturer=Huawei Technologies

S: Product=Huawei Mobile

S: SerialNumber=HUAWEI EC3X1

C:* #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA

I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=pl2303

E: Ad=81(I) Atr=03(Int.) MxPS= 16 Ivl=128ms

E: Ad=8a(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

E: Ad=0b(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=pl2303

E: Ad=83(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms

E: Ad=06(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

.....

.....

Now modprobe the driver

Code:

# modprobe usbserial vendor=0x12d1 product=0x1001

Should get something like this with dmesg

Code:

# dmesg

[ 2315.412106] usbcore: registered new interface driver usbserial

[ 2315.412508] drivers/usb/serial/usb-serial.c: USB Serial support registered for generic

[ 2315.461938] usbcore: registered new interface driver usbserial_generic

[ 2315.461945] drivers/usb/serial/usb-serial.c: USB Serial Driver core

[ 2315.480382] drivers/usb/serial/usb-serial.c: USB Serial support registered for pl2303

[ 2315.480414] pl2303 2-6:1.0: pl2303 converter detected

[ 2315.480608] usb 2-6: pl2303 converter now attached to ttyUSB0

[ 2315.480620] pl2303 2-6:1.1: pl2303 converter detected

[ 2315.480691] usb 2-6: pl2303 converter now attached to ttyUSB1

Now edit your wvdial.conf file

Code

# vi /etc/wvdial.conf

[Modem0]

Modem = /dev/ttyUSB0

Baud = 115200

SetVolume = 0

Dial Command = ATDT

Init1 = ATZ

FlowControl = Hardware (CRTSCTS)

[Dialer cdma]

Username = You Phone Number Here

Password = Your Password ... usually same as your phone number

Phone = #777

Stupid Mode = 1

Inherits = Modem0

Now run wvdial

Code:

# wvdial cdma

--> WvDial: Internet dialer version 1.56

--> Cannot get information for serial port.

--> Initializing modem.

--> Sending: ATZ

ATZ

OK

--> Modem initialized.

--> Sending: ATDT#777

--> Waiting for carrier.

ATDT#777

CONNECT 230400

--> Carrier detected. Starting PPP immediately.

--> Starting pppd at Sat Mar 3 22:55:20 2007

--> Pid of pppd: 24314

--> Using interface ppp0

--> local IP address 220.226.50.126

--> remote IP address 97.239.2.10

--> primary DNS address 202.138.103.100

--> secondary DNS address 202.138.96.2

Thats it ... you are now connected

Ensure that your internet traffic goes through your "Modem"

In Ubuntu ... this can be done @ System->Administration->Networking

Enjoy :o )

Dunno how to make this sticky ... if anyone can, please do it

dear sir,

my name is manickam i am using reliance wireless modem (MG880) i am new in linux framware so pls help me i am using ubuntu 7.10 but ware i want enter the code what ever you gave pls help me i am waitting for u r replay :confuse:

Share this post


Link to post
Share on other sites

please help me. I have a reliance net connectiom ( prepaid @ 115.2 kbps). I connect to Internet via bluetooth from my mobile (Sony Ericsson Z550i ). now I want to connect from fedora linux (v 8.0) and I can't do that, I can't setup network connection. Any body can help me what I have to do after installing the linux ?

Share this post


Link to post
Share on other sites

Hii..

plz help me... I'm a newbie to Fedora Core 8 and I wanted to connect to the net using my Reliance NetConnect (ZTE USB Modem)...Can anyone please help me with this.....

Share this post


Link to post
Share on other sites

Thanks Jungle_Boy.

this procedure worked for me in Ubuntu9.04 and with Huawei EC168C USB data card(Reliance Netconnect Broadband+ EVDO).

Share this post


Link to post
Share on other sites

Hi dear,

I have redhat 5 & m tring to install reliance netconnect on it, but it's recognized as cdrom, so m able to execute, it say's that there is no modem....NOTriste.gif

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now