avkavk

RConnect & Linux

141 posts in this topic

Hi,

I am using RADHET 9 linux, it is just now i am new in LINUX.

When i am going to activate my FWP with GENOME gui, it is giving error 2 or 8.

But when i am going in root and after changing in wvdial.conf file. It is connecting but i don't know how can i go for internet in command mode. i mean to say how can i browse a webpage in root, pls explain if anybody have LINUX knowledge.

After connection of FWP in root i switch to GUI mode but i am unable to access in web page.

pls help

42476[/snapback]

wvdial.conf is always owned by root in any Linux system but any user can connect after issuing "wvdial R" comand to connect. There is no need to browse a web page as root. Just open the browser as an ordinary user. If you are getting an error in the browser check the permission of the file /etc/resolv.conf it should be 644. If it is not change it by giving following command as root

chmod 644 /etc/resolv.conf
hi

i am using cierra wireless card for net access on win xp, i want to use it on my laptop with mandrake lynux, can anyone help me please?

41758[/snapback]

I have used my mobile instrument on Laptop with Mandrake Linux but I can guide you for Cierra wireless card only when you tell me the tty id being assigned by the system when you insert the card. I suggest you examine /var/log/messages file after you insert the card in the slot and post the tty id the system is assigning to the card.
I am using a local usb cable to connect my laptop to a 2030 lg phone and it works fine under win xp.

I want to use the same thing under linux fc4. Does anyone know which drivers to use.

WIndows lists it as an Ark MIcro usb to serial device.

Thanks

simrel

41636[/snapback]

There is no need for any separate driver. All latest Linux distributions (including FC4) are well equipped through hotplug to detect any USB device (including the mobile phone) and load the correct driver. Just see the /var/log folder for messages. After you connect the mobile phone the system assigns a tty id to the device. You should find out the tty id from the message and post it here.

kagashe

Share this post


Link to post
Share on other sites

since i am a novice to linux, can anyone pl. help HOW TO USE R-CONNECT ON RED HAT LINUX 9 using nokia 6585 step-by-step?

Edited by longanidnsp

Share this post


Link to post
Share on other sites

Download the drivers for your phone. Then execute the file using

sudo INSTALL.sh (or whatever the filename is.....)

Then follow the instructions on screen....

Share this post


Link to post
Share on other sites
Download the drivers for your phone. Then execute the file using

sudo INSTALL.sh (or whatever the filename is.....)

Then follow the instructions on screen....

45045[/snapback]

While you are guiding for using the script available on Reliance Infocom site please note two points:

1. SUDO is used only in Ubuntu. In other distributions the command is "su" for using root priviledges.

2.0 Every Linux distribution allots different tty # to the mobile instrument so the relevant file in the script needs to be changed. e.g. Mandrake detects it as

/dev/usb/tty/acm/0
and Ubuntu detects it as
/dev/ttyACM0
.

Redhat offcourse may be detecting as per the script and it may work without any modification.

You can have a look at my earlier post on this thread.

According to my experince by using the script you are connected at less speed compared to when you use wvdial.

kagashe

Edited by kagashe

Share this post


Link to post
Share on other sites

i tried configuring and using wvdial, but it dosen't shows any response to my nokia 6585

Share this post


Link to post
Share on other sites

Hi,

I recently installed new version of Ubuntu (Breezy 5.10) and had to install RConnect once again. Initially I tried wvdial after configuring it as per the post on this thread. It did not work. Then I installed the RConnect script, changed the link to /dev/ttyACM0 and tried to connect. It worked.

Then I tried wvdial once again and it worked.

It seems that it is necessary to install the RConnect script before trying wvdial on Ubuntu. Perhaps it configures pppd.

This is just a feedback for the people who are trying wvdial.

kagashe

1 person likes this

Share this post


Link to post
Share on other sites

Hello All,

I am using LG USB RD 6000 Rconnect phone to connect internet in Fedora core 3. I am using wvdial for connecting. I have configured my wvdial.conf and resolve.conf as follows.

1.file:/etc/wvdial.conf

[Modem0]

Modem= /dev/ttyACM0

Baud= 115200

SetVolume=0

DialCommand= ATDT

FlowControl= Hardware(CRTSCTS)

[Dialer R]

Username= my phone number

Password= my phone number

Phone= #777

Stupid Mode= 1

Inherits= Modem0

2. file:/etc/resolv.conf

service named start

nameserver 202.138.103.100

nameserver 202.138.97.193

nameserver 127.0.0.1

3. Connected Mobile to system using a USB cable

4. login as root

5. typed following command

modprobe uhci

modprobe usbserial

modprobe ftdi_sio

wvdial R

But my problem is after wvdial R it does not connect to net for long time. It continuously gives error PPP has died. Disconnecting...

After so many tries it suddenly gets connected. But after connecting it does not open any website. It opens only reliance website but that too after long time. I tried to open rediff, google but it says site could not found. Speed is extremely slow in linux. While its good in windows. I don't know how to overcome this situtaion.

Any suggestions

Thanks & Regards

Kavita

<TOPIC MERGED!>

Edited by Vishal Gupta

Share this post


Link to post
Share on other sites

Hello KavitaB,

Please download rconnect-cmdline-1.0.tar from:

http://www.relianceinfo.com/Infocomm/Rim/r...t_dc_linux.html

Untar it and install it as per instructions in README file (as root user)

After installation if you give "rconnect" command it won't connect initially but give you some error like device not found. Now you have to change the device link as follows:

Open file /etc/rconnect/rconnect.conf as root user.

Change the second field to /dev/ttyACM0 (It might be something like /dev/input/*)

Save the file.

Now try "rconnect" command in a terminal (as ordinary user)

This should work.

To disconnect "rdisconnect".

Now try "wvdial R" (as ordinary user)

It should work. If it does not use "rconnect as above.

Post here if you encounter any problems.

kagashe

Edited by kagashe

Share this post


Link to post
Share on other sites

hello,

I am using Centos 4(based on Redhat Enterprice Linux 3), May i connect my Nokia 2112 with CA-42 cable by your procedure ? Please help me. blazingbruce@gmail.com

----------------------------------

HI all,

after much strugle , i am connected to Internet from my Linux OS

here is the complete set of steps i followed (it took me 4 months and N number of Hr to Connect to Internet)

To Connect to Internet using Reliance Phone (any)

with Fedora core 3

I create a file in /etc/wvdial.conf

1.file:/etc/wvdial.conf

[Modem0]

Modem= /dev/ttyACM0

Baud= 115200

SetVolume=0

DialCommand= ATDT

FlowControl= Hardware(CRTSCTS)

[Dialer R]

Username= my phone number

Password= my phone number

Phone= #777

Stupid Mode= 1

Inherits= Modem0

2. edit following file as follow

file:/etc/resolv.conf

service named start

nameserver 202.138.103.100

nameserver 202.138.97.193

nameserver 127.0.0.1

3. change Mobile\settings\phone\datarate = 115200

4. now to dial to Internet we need to follow these things

5. Connect  Mobile to system using a USB cable

6. login as root

7. type following command

modprobe uhci

modprobe usbserial

modprobe ftdi_sio

wvdial R

Huuuuure I am connected to Internet

to disconnect

killall pppd

remove phone after some time

:good:

32240[/snapback]

Share this post


Link to post
Share on other sites
hello,

        I am using Centos 4(based on Redhat Enterprice Linux 3), May i connect my Nokia 2112 with CA-42 cable by your procedure ? Please help me. blazingbruce@gmail.com

----------------------------------

49897[/snapback]

Nokia 2112 is not mentioned on this page on Reliance India Mobile site. Please make sure whether your instrument (Nokia 2112) supports Linux or not.

If it does download Rconnect 1.0 from the web page (previous one) and follow the procedure I have suggested on my previous post.

kagashe

Share this post


Link to post
Share on other sites

i installed the Fedora core 4 yday but i am not able to figure out how to connect rconnect via usb and serial.

does any body know how to set rconnect connection on Fedora core 4?

pls help

Edited by cracker

Share this post


Link to post
Share on other sites

Dear All,

I have been using FWP LG350R phone for connecting to internet. I have installed it on windows 2000 operating system.

I tried doing the same for Linux operating system. Ultimately, i could not install. Can any one guide me to install. If i need to download the driver, where can i get it.

Regards,

Satish

<TOPIC MERGED!>

Edited by Vishal Gupta

Share this post


Link to post
Share on other sites

I was using rconnect in my PCQLinux 2004 distro when I had and LG RD2130 phone. But now with LG RD6130 handset I can not connect . The /var/log/messages say "vendor/product 1004/6000 not claimed by any active driver". Though LGE CDMA phone is detected by Kudzu - it says "insmod acm failed"

;)

Please help

<TOPIC MERGED!>

Edited by Vishal Gupta

Share this post


Link to post
Share on other sites

Guys!

Yesterday I installed Fedora Core 3 on my system and also installed RConnect drivers for my Lg LSP 340E.

It detected the phone and installed the drivers successfully!

When I gave rconnect command in terminal, it connected successfully but I was not able to open ne site in the browser!

Then I read following post of Dhananajay:

HI all,

after much strugle , i am connected to Internet from my Linux OS

here is the complete set of steps i followed (it took me 4 months and N number of Hr to Connect to Internet)

To Connect to Internet using Reliance Phone (any)

with Fedora core 3

I create a file in /etc/wvdial.conf

1.file:/etc/wvdial.conf

[Modem0]

Modem= /dev/ttyACM0

Baud= 115200

SetVolume=0

DialCommand= ATDT

FlowControl= Hardware(CRTSCTS)

[Dialer R]

Username= my phone number

Password= my phone number

Phone= #777

Stupid Mode= 1

Inherits= Modem0

2. edit following file as follow

file:/etc/resolv.conf

service named start

nameserver 202.138.103.100

nameserver 202.138.97.193

nameserver 127.0.0.1

3. change Mobile\settings\phone\datarate = 115200

4. now to dial to Internet we need to follow these things

5. Connect Mobile to system using a USB cable

6. login as root

7. type following command

modprobe uhci

modprobe usbserial

modprobe ftdi_sio

wvdial R

Huuuuure I am connected to Internet

to disconnect

killall pppd

remove phone after some time

After it I Gave the same BOLD lines in resolve.conf file and VOILLA, the browser started opening sites without ne problem!

Now my question is! What following lines mean:

service named start

nameserver 202.138.103.100

nameserver 202.138.97.193

nameserver 127.0.0.1

And should I write also same lines in the file or is there ne method to find out which IP addresses should be written there?

Share this post


Link to post
Share on other sites
Guys!

Yesterday I installed Fedora Core 3 on my system and also installed RConnect drivers for my Lg LSP 340E.

It detected the phone and installed the drivers successfully!

When I gave rconnect command in terminal, it connected successfully but I was not able to open ne site in the browser!

When you use RConnect for the first time /etc/resolv.conf file is written automatically but the file has only root (or SU permission), therefore, you are not able to surf any site as ordinary user. If you simply change the file permission to 644 (as root) you can surf as ordinary user.
After it I Gave the same BOLD lines in resolve.conf file and VOILLA, the browser started opening sites without ne problem!
The file permission would have also changed when you wrote the file.

Now my question is! What following lines mean:

service named start

nameserver 202.138.103.100

nameserver 202.138.97.193

nameserver 127.0.0.1

And should I write also same lines in the file or is there ne method to find out which IP addresses should be written there?

These are DNS servers of Reliance which resolve the URL you type into IP addresses so that you can surf. Don't worry about writing anything in the file since the file is written every time you connect.

If you face the problem (unable to surf) again just check the file permission of /etc/resolv.conf and change it to 644.

I would also like another feedback from you. Goto:

http://testmy.net/

and check the speed you are getting using RConnect script.

Then install wvdial using Dhananjay's method and connect using wvdial (instead of Rconnect script) and check the speed once agiain. Tell me if you find a difference.

My experince is you get much better speed using wvdial compared RConnect (I don't know why, although, RConnect passes the correct command to pppd).

kagashe

Share this post


Link to post
Share on other sites

Hi,

I understand that the mobile phone whose chipset is supported in Linux can only be used in Linux. There is a recommened list of Linux supported phones on Reliance website:

http://www.relianceinfo.com/Infocomm/Rim/r...t_dc_linux.html

Incidentally it does not recommend any Nokia phone. Also most of the models are not available now.

Reliance website is silent about Linux compatibility of Sierra RConnect card, although, people are using it.

I suggest we start a thread where people using Linux post their phone model, RConnect Card model (I understand 2 more cards are available apart from Sierra now).

I purchased GTran handset because it was listed on Reliance website but I am fed up now with the batteries and the charger. I would like to know whether the new RConnect cards could be used on Linux.

kagashe

Share this post


Link to post
Share on other sites

thnx for this clearification!!!

I'll definitely try wvdial also...

Share this post


Link to post
Share on other sites

it is damm easy to connect dialup connection on linux

i just installed it on fedora 4:)

post-6898-1137577971_thumb.jpg

Edited by cracker

Share this post


Link to post
Share on other sites
modrobe uhci

modprobe usbserial

modprobe ftdi_sio

wvdial R

Why do you need to add bove 3 modules while using phone as a modem? What does uhci, ftdi_sio and usbserial means?

I guess we do not need to add these modules while using data card to connect to internet?

If anyone has answer to this question please reply.

Regards,

Kavita

Share this post


Link to post
Share on other sites

hi everyone

i registered to this site a few days ago and find that many people are having problems running internet from their NOKIA handsets on linux. I have a NOKIA 3125 and this is how I did it.

I made two configuration files. The first is the file that gives pppd its options and the second is the file that tells pppd the username and password to use in order to log into the ISP.

File: /etc/ppp/options

Perms: 640 (-rw-r-----)

Owner: root.root

This is the pppd options file. It looks like the following (without the dashes):

---------------------------

updetach

modem

lock

crtscts

defaultroute

asyncmap 0

---------------------------

File: /etc/ppp/pap-secrets

Perms: 640 (-rw-r-----)

Owner: root.root

This is the file that contains the username and password for the ISP. The password must be in clear text. It should look like the following (without dashes):

---------------------------

username * password

---------------------------

I also made three script files

These are the files that actually connect you to the ISP. There are a total of three scripts that connect and disconnect you from the Internet.

File: /etc/ppp/ppp-on

perms: 750

Owner root.root

This is the actual connect script. You will need to edit the script with your username and telephone number to dial in the correct locations, after which, run it and you should connect.

---------------------------

#!/bin/sh

USERNAME= # Your username goes here

TELEPHONE=#777 # The telephone number you dial to connect

LOCAL_IP=0.0.0.0 # Local IP address if known. Dynamic = 0.0.0.0

REMOTE_IP=0.0.0.0 # Remote IP address if desired. Normally 0.0.0.0

export TELEPHONE ACCOUNT PASSWORD

DIALER_SCRIPT=/etc/ppp/ppp-on-dialer

exec /usr/sbin/pppd debug /dev/ttyUSB0 115200 name $USERNAME \

$LOCAL_IP:$REMOTE_IP \

connect $DIALER_SCRIPT

# use /dev/USB* or /dev/ACM* as per your requirement

cat /etc/resolve.conf >> /etc/resolv.conf

----------------------------

File: /etc/ppp-on-dialer

Perms: 750

Owner: root.root

This script actually performs the dialing function. It receives the telephone number from ppp-on. If you wish, you may add a modem initialization string where indicated. If you do not wish for a initialization string then remove the line completely.

----------------------------

#!/bin/sh

exec /usr/sbin/chat -v \

TIMEOUT 3 \

ABORT '\nBUSY\r' \

ABORT '\nNO ANSWER\r' \

ABORT '\nRINGING\r\n\r\nRINGING\r' \

'' \rAT \

'OK-+++\c-OK' ATH0 \

OK 'AT+CRM=1;+CSO=33' \

TIMEOUT 30 \

OK ATDT$TELEPHONE \

CONNECT '' \

----------------------------

File: /etc/ppp/ppp-off

Perms: 750

Owner: root.root

This is the script that will disconnect you from the Internet. No modifications are necessary.

----------------------------

#!/bin/sh

if [ "$1" = "" ]; then

DEVICE=ppp0

else

DEVICE=$1

fi

if [ -r /var/run/$DEVICE.pid ]; then

kill -INT `cat /var/run/$DEVICE.pid`

if [ ! "$?" = "0" ]; then

rm -f /var/run/$DEVICE.pid

echo "ERROR: Removed stale pid file"

exit 1

fi

echo "PPP link to $DEVICE terminated."

exit 0

fi

echo "ERROR: PPP link is not active on $DEVICE"

exit 1

----------------------------

also create /etc/resolve.conf as follows

nameserver 202.138.103.100

nameserver 202.138.97.193

nameserver 127.0.0.1

now to run the script cd /etc/ppp

sh ppp-on and ENJOY!!!!! :P

sometome ppp-off does not disconnect

then killall pppd

and then sh ppp-on again

data call definitely end now

I FEEL this WILL WORK ON ANY NOKIA PHONE. IN CASE IT DOESNT PLEASE POST YOUR PROBLEM

IF IT DOES THEN TOO PLEASE SHARE YOUR EXPERIENCE

Edited by paraj

Share this post


Link to post
Share on other sites

if u want to connect rconnect through any user account........

without logging out and logging in as root. Try following command

su -

it will ask for password, type root password and press enter and

than type rconnect if u r using r connect script or wvdial R if u r using wvdial script

and it will connect r connect successfully

Edited by cracker

Share this post


Link to post
Share on other sites
Hi,

I am trying to connect to internet from FC3 via nokia(reliance-CDMA)-6225. But everytime during connection setup, it fails saying "NO CARRIER". Please let me know if you have tried any nokia(CDMA)-Linux combination? Thanks in advance.

--

Cheers

~Sas

PS. I used all the extra initialization command like AT+CRM=30, +CSO=33

:cheer:

the correct initialization string is AT+CRM=1;+CSO=33

i use nokia 3125 but still had some problem connecting via kppp.

i case you have the same try out the scripts i posted earlier on the same topic

Edited by paraj

Share this post


Link to post
Share on other sites

Hello lAll,

I am using Nokia 3125 CDMA model and wanted to use this phone to connect to internet in Fedora core 3. I connected c4-A2 data cable to USB port and to phone. On running dmesg it gave following 2 lines at the end.

drivers/usb/class/cdc-acm.c: This device cannot do calls on its own. It is no modem.

cdc_acm 3-1:1.0: ttyACM0: USB ACM device

I am using following wvdial.conf file

[Modem0]

Modem= /dev/ttyACM0

Baud= 115200

SetVolume= 0

DialCommand= ATDT

FlowControl= Hardware(CRTSCTS)

Dial Command = ATDT

Init = AT+CRM=1;+CSO=33

[Dialer R]

Username= my phone

Password= my phone

Phone= #777

Stupid Mode= on

Inherits= Modem0

My /etc/ppp/options lis as follows

lock

asyncmap 0

crtscts

modem

defaultroute

usepeerdns

noauth

/dev/ttyACM0 115200

also I included following module

modeprobe uhci

modprobe usbserial

modprobe ftdi_sio

and ran wvdial R which gave following output

--> WvDial: Internet dialer version 1.54.0

--> Initializing modem.

--> Sending: AT+CRM=1;+CSO=33

AT+CRM=1;+CSO=33

OK

--> Modem initialized.

--> Sending: ATDT#777

--> Waiting for carrier.

ATDT#777

CONNECT

--> Carrier detected. Starting PPP immediately.

--> Starting pppd at Thu Feb 9 10:07:47 2006

--> pid of pppd: 4181

--> Disconnecting at Thu Feb 9 10:07:49 2006

--> The PPP daemon has died: Fatal pppd error (exit code = 1)

--> man pppd explains pppd error codes in more detail.

--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.

man pages of pppd says that exit code=1 means

1 An immediately fatal error of some kind occurred, such as an essential system call failing, or running out of virtual memory.

On checking /var/log/messages file I found following lines

Feb 9 10:07:58 localhost pppd[4197]: pppd 2.4.2 started by root, uid 0

Feb 9 10:07:58 localhost pppd[4197]: Couldn't get channel number: Input/output error

Feb 9 10:07:59 localhost pppd[4197]: Exit.

I am not getting why it is giving "couldn't get channel number"

Does anyone know this error?

Please help me.

Regards,

Kavita

Share this post


Link to post
Share on other sites
hi everyone

i registered to this site a few days ago and find that many people are having problems running internet from their NOKIA handsets on linux. I have a NOKIA 3125 and this is how I did it.

I made two configuration files. The first is the file that gives pppd its options and the second is the file that tells pppd the username and password to use in order to log into the ISP.

File: /etc/ppp/options

Perms: 640 (-rw-r-----)

Owner: root.root

This is the pppd options file. It looks like the following (without the dashes):

---------------------------

updetach

modem

lock

crtscts

defaultroute

asyncmap 0

---------------------------

File: /etc/ppp/pap-secrets

Perms: 640 (-rw-r-----)

Owner: root.root

This is the file that contains the username and password for the ISP. The password must be in clear text. It should look like the following (without dashes):

---------------------------

username * password

---------------------------

I also made three script files

These are the files that actually connect you to the ISP. There are a total of three scripts that connect and disconnect you from the Internet.

File: /etc/ppp/ppp-on

perms: 750

Owner root.root

This is the actual connect script. You will need to edit the script with your username and telephone number to dial in the correct locations, after which, run it and you should connect.

---------------------------

#!/bin/sh

USERNAME= # Your username goes here

TELEPHONE=#777 # The telephone number you dial to connect

LOCAL_IP=0.0.0.0 # Local IP address if known. Dynamic = 0.0.0.0

REMOTE_IP=0.0.0.0 # Remote IP address if desired. Normally 0.0.0.0

export TELEPHONE ACCOUNT PASSWORD

DIALER_SCRIPT=/etc/ppp/ppp-on-dialer

exec /usr/sbin/pppd debug /dev/ttyUSB0 115200 name $USERNAME \

$LOCAL_IP:$REMOTE_IP \

connect $DIALER_SCRIPT

# use /dev/USB* or /dev/ACM* as per your requirement

cat /etc/resolve.conf >> /etc/resolv.conf

----------------------------

File: /etc/ppp-on-dialer

Perms: 750

Owner: root.root

This script actually performs the dialing function. It receives the telephone number from ppp-on. If you wish, you may add a modem initialization string where indicated. If you do not wish for a initialization string then remove the line completely.

now to run the script cd /etc/ppp

sh ppp-on and ENJOY!!!!! :rolleyes:

Hi paraj,

I used your script to connet my Nokia 3125 CDMA phone for connecting to internet in Fedora core 3. On running sh ppp-on first time its gave me following output

[root@localhost ppp]# sh ppp-on

ppp-on: line 3: my phone no: command not found

Serial connection established.

using channel 3

Using interface ppp0

Connect: ppp0 <--> /dev/ttyACM0

rcvd [LCP ConfReq id=0x1 <mru 1514> <asyncmap 0x0> <auth pap> <magic 0x3700eea2> <pcomp> <accomp>]

sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x1b612e8f> <pcomp> <accomp>]

sent [LCP ConfAck id=0x1 <mru 1514> <asyncmap 0x0> <auth pap> <magic 0x3700eea2> <pcomp> <accomp>]

rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x1b612e8f> <pcomp> <accomp>]

sent [PAP AuthReq id=0x1 user="229323170906" password=<hidden>]

rcvd [PAP AuthNak id=0x1]

PAP authentication failed

sent [LCP TermReq id=0x2 "Failed to authenticate ourselves to peer"]

sent [LCP TermReq id=0x3 "Failed to authenticate ourselves to peer"]

Connection terminated.

I am using my phone no in USERNAME of ppp-on script and it says that command not found . Also I couldn't get meaning of "export TELEPHONE ACCOUNT PASSWORD" Form where this script will get ACCOUNT and PASSWORD information. Please help me in connecting this phone in linux.

regards,

Kavita

Share this post


Link to post
Share on other sites

My phone is LG-5130.And i am using SUSE9.1.How can i connect it.

Plz HELP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now