avkavk

RConnect & Linux

141 posts in this topic

Hi, all

Any body know updated driver for LSI 110 ?? reason the driver which i download RIM Site that does not working @ all with Redhat AS 3.0 and AS 4.0 any other source ???

updated me ?

:angry:

Regards,

Niri

<TOPIC MERGED!>

Edited by Vishal Gupta

Share this post


Link to post
Share on other sites
Hi, all

Any body know updated driver for LSI 110 ?? reason the driver which i download RIM Site that does not working @ all with Redhat AS 3.0 and AS 4.0 any other source ???

updated me ?

:rolleyes:

Regards,

Niri

<TOPIC MERGED!>

Hi,

LS 110 has native USB CDC interface, and distributions you mentioned does have CDC

ACM support built in, you don't need any other updated or not driver for that.

If it's not getting loaded automatically you could do "modprobe cdc-acm" on the console or put this line in your /etc/rc.d/rc.local

/sbin/modprobe /lib/modules/$(uname -r)/kernel/drivers/usb/class/cdc-acm.ko

{ this module path is specific to 2.6.xx series kernel, its been long time since I used 2.4 series so you may have to look out for path, but "/lib/modules/" is the place where it get installed.

Do "dmesg | grep tty" and look for ttyACMn /n := 0...n/

BTW what kinda script are you using to fire up the pppd and associated helpers and please provide details of the problem you exactly are having ?

Share this post


Link to post
Share on other sites

I have lgrd 5340 recently bought. I have lg rd 5130's USB cable.

I am trying to connect to internet thru this data cable on my linux machine.

I am using same script which i was using for 5130. but doesnt work.

also my machine can not detect any modem.

thanks in advance.

Share this post


Link to post
Share on other sites

Hi,

Can someone please help me setup internet connection on my Linux machine (I am using Suse 9.3)?

I have a Reliance FWP connection (LG - LSI 110 instrument).

Do I need to provide any addresses like gateway server's or DNS servers' or if I just chose DHCP, it'll get these settings from the Reliance network?

I am able to connect using this phone from my Windows XP but on Linux, I am getting "Data Service Unavailable".

If someone has gotten this error and resolved it, please take out some time to help me out. I'll really appreciate the help.

rgds,

Roshan

<TOPIC MERGED!>

Edited by Vishal Gupta

Share this post


Link to post
Share on other sites

as far as i know, there are rconnect packs available for linux as well on the reliace download site, trying that would be your best bet.

Share this post


Link to post
Share on other sites

Hi,

I got this card yesterday and trying to get it working on my thinkpad with redhat fedora core5.

The card gets detected as soon as it is inserted into the pcmcia slot. And is assigned ttyS3. But

I am not able to use it via minicom , wvdial or kppp. Via minicom no response from the modem.

Same with wvdial and kppp. Has anybody got this card working under linux ?

Thanks and Regards,

Satish/

EDIT by Vishal Gupta: < Topic Merged >

Share this post


Link to post
Share on other sites
Hi,

I got this card yesterday and trying to get it working on my thinkpad with redhat fedora core5.

The card gets detected as soon as it is inserted into the pcmcia slot. And is assigned ttyS3. But

I am not able to use it via minicom , wvdial or kppp. Via minicom no response from the modem.

Same with wvdial and kppp. Has anybody got this card working under linux ?

Thanks and Regards,

Satish/

How did u configure yout port settings?

Share this post


Link to post
Share on other sites
How did u configure yout port settings?

As soon as I insert the card it gets detected and I see following message in "dmesg"

<snip>

pccard: PCMCIA card inserted into slot 0

cs: memory probe 0xd0000000-0xd7ffffff: excluding 0xd0000000-0xd7ffffff

cs: memory probe 0xb4000000-0xbfffffff: excluding 0xb4000000-0xb47fffff 0xb6000000-0xb7ffffff

pcmcia: registering new device pcmcia0.0

ttyS3: detected caps 00000700 should be 00000100

0.0: ttyS3 at I/O 0x2e8 (irq = 3) is a 16C950/954

</snip>

setserial shows :-

[root@hominid ~]# setserial -av /dev/ttyS3

/dev/ttyS3, Line 3, UART: 16950/954, Port: 0x02e8, IRQ: 3

Baud_base: 115200, close_delay: 50, divisor: 0

closing_wait: 3000

Flags: spd_normal skip_test

But using minicom or wvdial doesn't yield any results.

Here's the output from wvdialconf

<snip>

[root@hominid ~]# wvdialconf test.conf

Scanning your serial ports for a modem.

ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud

ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud

ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.

Port Scan<*1>: S1 S2

ttyS3<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud

ttyS3<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud

ttyS3<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.

Sorry, no modem was detected! Is it in use by another program?

Did you configure it properly with setserial?

</snip>

Any thoughts?

Share this post


Link to post
Share on other sites

How did u configure yout port settings?

As soon as I insert the card it gets detected and I see following message in "dmesg"

<snip>

pccard: PCMCIA card inserted into slot 0

cs: memory probe 0xd0000000-0xd7ffffff: excluding 0xd0000000-0xd7ffffff

cs: memory probe 0xb4000000-0xbfffffff: excluding 0xb4000000-0xb47fffff 0xb6000000-0xb7ffffff

pcmcia: registering new device pcmcia0.0

ttyS3: detected caps 00000700 should be 00000100

0.0: ttyS3 at I/O 0x2e8 (irq = 3) is a 16C950/954

</snip>

setserial shows :-

[root@hominid ~]# setserial -av /dev/ttyS3

/dev/ttyS3, Line 3, UART: 16950/954, Port: 0x02e8, IRQ: 3

Baud_base: 115200, close_delay: 50, divisor: 0

closing_wait: 3000

Flags: spd_normal skip_test

But using minicom or wvdial doesn't yield any results.

Here's the output from wvdialconf

<snip>

[root@hominid ~]# wvdialconf test.conf

Scanning your serial ports for a modem.

ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud

ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud

ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.

Port Scan<*1>: S1 S2

ttyS3<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud

ttyS3<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud

ttyS3<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.

Sorry, no modem was detected! Is it in use by another program?

Did you configure it properly with setserial?

</snip>

Any thoughts?

Hi ,

If its sierra AirCard or compatibles then see this link.

http://centerclick.org/aircard555/

Share this post


Link to post
Share on other sites

Hi,

When i insert my ZTE MC 315 pcmcia card and do a dmesg it shows :

pccard: PCMCIA card inserted into slot 0

pcmcia: registering new device pcmcia0.0

ttyS3: detected caps 00000700 should be 00000100

0.0: ttyS3 at I/O 0x2e8 (irq = 3) is a 16C950/954

it is bound to serial_cs

and when i do a pccardctl info it shows:

PRODID_1="CDMA1X"

PRODID_2="CARD"

PRODID_3=""

PRODID_4=""

MANFID=0279,950b

FUNCID=2

PRODID_1=""

PRODID_2=""

PRODID_3=""

PRODID_4=""

MANFID=0000,0000

FUNCID=255

I also created a wvdial.conf entry as following:

[Dialer Defaults]

Modem = /dev/ttyS3

Init1 = ATZ

ISDN = 0

Carrier Check = no

Stupid Mode = yes

Modem Type = Analog Modem

Phone = #777

Username = [myphonenumber]

Password = [myphonenumber]

and when i do wvdial:

--> WvDial: Internet dialer version 1.54.0

--> Initializing modem.

--> Sending: ATZ

--> Sending: ATQ0

--> Re-Sending: ATZ

--> Modem not responding.

I understand that ZTE card config information is not there , i couldnt find it on thier website too

Can somebody please guide me, im kinda frustrated with my first linux experiance, but im adament in using it rather than windows

Thanx N Regards

Mat

EDIT by Vishal Gupta: < Topic Merged >

Share this post


Link to post
Share on other sites

Hi Beloved Friends!

I am a new member of your forum. And.... I am here expecting some help from you to solve my problem I am facing.

Problem Description::

I am a user of Fedora Core 1 and I have one LG LSI 110 USB Cordless phone provided by Reliance. Now, I have downloaded the Linux software from Reliance website to connect Fedora Core 1 to the net with this phone model. Though the software specification says it has been ideal for Linux 8.0 but I have tried it on my Fedora Core 1. And... after going through the driver installation instruction of Reliance bundled with the download pack, this phone model is not being recognised by Fedora Core 1 and it redirects to view the log file at the location /var/log/messages to look for what type of errors occured, truly speaking that is not understood by me.

So, please help me how can I get connected to the internet through my LG LSI 110 USB Cordless phone & Fedora Core 1.

For your convenience I have attached herewith the Linux driver of RConnect that I tried to be connected to the net.

rconnect_cmdline_1.0.rar

EDIT by Vishal Gupta: < Topic Merged >

Share this post


Link to post
Share on other sites

Guys,

I think surfing on linux is a pleasure when compared with windows. On linux both wvdial and kppp can be made configured to re-connect if the net is disconnected. I am using freedom at night plan and often the network will go down, with linux i can configure the same to reconnect but on windows i don't know how to do the same.

Am using bluetooth dongle and nokia 6265 for the same. If any one is interested i can paste bluetooth -> hcid.conf etc, wvdial.conf settings.

Cheers,

nitro

Share this post


Link to post
Share on other sites

:help: ....

hi all

...i was trying to configure rconnect on suse 10.0 but no end to my miseries......i tried the solution provided on reliance site but it wont detect my phone...

...plz put up sumthin...

EDIT by Vishal Gupta: < Topic Merged >

Share this post


Link to post
Share on other sites

Hi ,

I am using fedora 4 trying to connect r-connect with lg 2030 and usb data cable

when i connect data cable and phone the /var/log/messages shows

Sep 6 23:38:45 localhost kernel: usb 4-1: new full speed USB device using uhci_hcd and address 4

Sep 6 23:40:01 localhost crond(pam_unix)[16298]: session opened for user root by (uid=0)

how do i know which usb port i have connected to ???

I've tried configuring kppp on all listed ports but could not detect modem thru query modem

i've also tried r-connect software given on Reliance website

i changed the r-connect config file settings from

/dev/modem

to

/dev/usb/ttyACM0

/dev/usb/ttyACM1

/dev/usb/ttyACM2

.

.

.

.

.

/dev/usb/ttyACM7

but none worked

i have 8 usb ports on my system

Can any one help me fix this ..................

thanks

Share this post


Link to post
Share on other sites
:SI:

Here is how you can configure the RConnect modem on Fedora core. You have to use kppp to dial. Just configure the settings as per the image given below and you are done. It works great with speed up to almost 110 kbps and no line drops stays connected untill you drop the line.

While creating modem either select ttyS0 if you have serial cable and

/dev/usb/ttyACM0 if you are using USB port. Replace the 0 with the appropriate port number here it can range from 0 to 4 or even more depending upon how many serial and usb ports that you have. Replace the Initialization string with that one which is suitable for your phone. You can find this string in the linux driver that reliance ships on its web site or just call them and they will tell you or use google or go through the manual that accompanies your phone.

Just works ...

No more hassles and pain.

Hi....I am new to linux world....but i love it.....i use mandriva 2006 linux.....but the problem is I have a FWP LG LSP-340E which i use to connect to internet......it works fine in windows XP+SP2.....i use a usb cable for connecting the phone to the PC......but when I connect the phone to the PC while in Linux environment.....I am unable to find out where Linux is mounting the USB.......I saw all the tricks given in this forum but when the USB is connected.....i cant find any folder such as dev/usb/......

I viewed the message in /var/log/messages but only found that it shows this message

Sep 7 11:44:34 localhost kernel: usb 1-1: new full speed USB device using uhci_hcd and address 3

what does this mean??????

Previously iwas using FC5 but was getting same kind of message and unable to find out a solution.....I switched to Mandrive in a hope that it would ease out some pain but nothing went better.....

More over I used a serial cable of my friend to experiment with and I was succesful in making the connection using the following setting.......

/dev/ttyS1

Can anybody please help me out in figuring out the problem........Plz tell me where the usb device gets mounted.......only then I could go furthur to configure wvdial......or RConnect software.....

Plz help me and thanx in advance

Share this post


Link to post
Share on other sites

Hi

I have an LG LSI 110 landline phone. I am trying to connect internet in Fedora core 5.

I have read lots of previous posts, was able to detect modem, but the purpose is still unsolved.

I did the following reading a previous post:

----------------------------------------------------------------------

I create a file in /etc/wvdial.conf

1.file:/etc/wvdial.conf

[Modem0]

Modem= /dev/ttyACM0

Baud= 115200

SetVolume=0

DialCommand= ATDT

FlowControl= Hardware(CRTSCTS)

[Dialer R]

Username= my phone number

Password= my phone number

Phone= #777

Stupid Mode= 1

Inherits= Modem0

2. edit following file as follow

file:/etc/resolv.conf

service named start

nameserver 202.138.103.100

nameserver 202.138.97.193

nameserver 127.0.0.1

3. change Mobile\settings\phone\datarate = 115200

4. now to dial to Internet we need to follow these things

5. Connect Mobile to system using a USB cable

6. login as root

7. type following command

modprobe uhci

modprobe usbserial

modprobe ftdi_sio

wvdial R

---------------------------------------------------------------

it detected my LG modem, started dialling, but my phone was showing connection failed try later

Also it was redialling very fast

I started windows and connected to internet just to check that there is no problem with connection.

there wasn't

so anybody can please help me with this

i am newbie so please tell me in detail

< Topic Merged >

Edited by Vishal Gupta

Share this post


Link to post
Share on other sites

I am having an LG RD6330 Mobile.

Works for me with the following amendments:

1. In wvdial.conf, changed this line like this: Modem=/dev/ttyUSB0

2. additional step: In my mobile, settings - phone - data settings - data in - On

Tested as root. For other users, some permission settings might be required.

Share this post


Link to post
Share on other sites

Hello Friends...

I have Samsung N191 Handset. And I use Internet in XP frm this handset. Actually my company gave me a project in Linux. For completing that project I need to be connected with Internet in Linux. But I am facing some problems to connect to Internet from this handset. :clap::( :( :(

I have installed Kubuntu 6.06... and for internt i have downloaded the rconnect_cmdline.tar file and exctracted it and finally i installed it by using this command.. # sh install.sh...and then i followed the instructions accordingly...

but when i am connecting to internet by # "sudo rconnect" then i am not able to connect... frnds plz help me to solve this plz... its my companies project.. so its urgent... plz guide me... i have given a screenshot of my problem in this post also....

btw i have seen some posts before posing this thread... and i saw that one guy told that u must have BIND installed.. but i dont have bind here (/etc/resolv.conf)[resolv.conf doesn't exist here]... so do i have to install bind or if i will create a file as resolv.conf manually and will edit the line, then will it solve the prob??? And one more thing... if i will install bind from # "dpkg -i bind9.deb" then i m sure that there may be dependancy files missing... so when installing packages its better to be connected to internet as it helps u to get the dependancy files.... but i m not able to connect :(:( :(

frnds i hope i will get the ultimate solutions frm all of you... i am very worried frnds.. plz suggest me something on how to solve this prob...and plz tell all the steps from beginning plz... so i will not face any prob regarding any commnds or any configs... this really made me frustrated... :(:clap:

Regards

Eldergeek

Here is the Screenshot :

post-14353-1158877273_thumb.png

EDIT by Vishal Gupta: < Topic Merged >

Edited by Vishal Gupta

Share this post


Link to post
Share on other sites

I did not download anything; just following the manual instructions (of editing /etc/wvdial......see the two posts above) did the trick for me.

Share this post


Link to post
Share on other sites

Hey Friends...

I am facing a serious problem in my Samsung N191 Handset. I am really confused that whether its Handset problem or my Linux Version Problem...

Actually when i am plugging my handset with my laptop via usb then its immediately getting switched off :Ohhhh::( so i am unable to connect to internet... and sometimes the mobile is getting hanged... i am using kubuntu 6.06 .. but its not happenning in my win xp pro.. its running cool without any problem... but in linux case it sux.. why :( ?? plz help... i did another test too.. i started my lap and plugged the cell with the usb.. and then started win os... and its not switching off but when i start linux then even from the boot time the cell is getting switched off... :( is this the prob of my kubunutu or the cell?? i dont think its cell prob (may :) ... coz its fine in win then why its a problem 4 linux ?? :(

Plz HELP Plz

:help:

Share this post


Link to post
Share on other sites

just type following command

sudo wvdialconf

and post the output

Edited by cracker

Share this post


Link to post
Share on other sites

The page you are looking for might have been removed, had its name changed, or is temporarily unavailable. You can also search the Internet to find the information you are looking for

http://mms.relianceinfo.com/mms/do

how to see

reply : parekh.rohit@gmail.com

Share this post


Link to post
Share on other sites

@abhay ah thanx mate :)

@Eldergeek rconnect dialer is useless don't use it

just go to shell mode by pressing

ctrl+alt+f2

than type sudo wvdialconf

it will scan and detect mobile port than go to etc directory /etc

and open wvdial.conf file

sudo vi wvdial.conf

than press i to enter in insert mode

enter following line in it

SetVolume=0

DialCommand= ATDT

FlowControl= Hardware(CRTSCTS)

[Dialer R]Username= my phone number

Password= my phone number

Phone= #777

Stupid Mode= 1

Inherits= Modem0

and save it by pressing ESC and entering

wq

now type sudo wvdial

and here u go u r now connected to net @the speed supported by ur mobile :(

now press ctrl+alt+f7 to exit shell mode open firefox and enjoy surfing

Edited by cracker

Share this post


Link to post
Share on other sites

Thnx mate.. i will definitely give it a try and will post if i will get success or any troubleshoots....

but what i will do to this thing -> /dev/input/ttyACM0 ?? will i change it to /dev/ttyS0 or /dev/tttyS1 or somethng else??

btw i have posted another thing is that why the mobile gets hanged//switched off in linux when connecting with my lap... ... sometimes it gets hanged and sometimes it shows some garbage values etc etc... (even shuts down from the linux bootup times when all the device daemons are getting loaded)... :-S :-S

but this is not happenning in the case of winxp.. the cell is running smoothly without any prob....

so any guesses??? what's the prob???

is it happenning fr kubuntu ?? if i will install red hat enterprise then will this prob will not happen??? i need some answers from u frds.. plz help me to patch it up plz...

IF ONCE MY PROB WILL BE SOLVED THEN I WILL COME WITH AWESOME WORKS FOR RIMWEB... I MEAN AWESOME POSTS AND ETC ETC... U CAN KNOW ABT IT LATER WHEN I WILL BE PLUGGED IN INTERNET IN MY LINUX BOX...

(sorry for using caps) i just wanted to give priorities in my words... if u want then u may modify or delete this line.. its upto u..

Regards

Eldergeek

Edited by Eldergeek

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now