Jump to content
Reliance Jio & Reliance Mobile Discussion Forums
avkavk

RConnect & Linux

Recommended Posts

avkavk    0

:clap:

Here is how you can configure the RConnect modem on Fedora core. You have to use kppp to dial. Just configure the settings as per the image given below and you are done. It works great with speed up to almost 110 kbps and no line drops stays connected untill you drop the line.

While creating modem either select ttyS0 if you have serial cable and

/dev/usb/ttyACM0 if you are using USB port. Replace the 0 with the appropriate port number here it can range from 0 to 4 or even more depending upon how many serial and usb ports that you have. Replace the Initialization string with that one which is suitable for your phone. You can find this string in the linux driver that reliance ships on its web site or just call them and they will tell you or use google or go through the manual that accompanies your phone.

Just works ...

No more hassles and pain.

post-4466-1115019020_thumb.jpg

Share this post


Link to post
Share on other sites
Arun    789

Thats gr8, I am planning to install Fedora soon, so your findings will surely help me :confuse:

Share this post


Link to post
Share on other sites
niket    0

for some models. u needs to tweak udev scripts.(specially if u r using r-connect script provided by reliance)

now with udev u can mount your device anywhere u like.

BTW,

In above pic shown "Intialization String 1" may varies with model to model.

that u can look up from your windows installation for same model.(Control Panel > Phone and Modem > Modem Tab > {Click LG/Samsung/Nokia usb Modem} > Advance Tab)

I used r-connect on FC3 for 2 months 8 hrs a day. and ones install find much stable then on windows-xp.

Share this post


Link to post
Share on other sites
Arun    789

done !

Share this post


Link to post
Share on other sites
Ganesh    0

in My FC3 which came with pcquest , i can see the usb serial converter listed in the usbview menu, but i cant connect using /dev/ttyUSB0.can someone help me by giving the right step by step guidelines to test the usb cable using minicom or any other serial port utility? :o

Share this post


Link to post
Share on other sites
niket    0
in My FC3 which came with pcquest , i can see the usb serial converter listed in the usbview menu, but i cant connect using /dev/ttyUSB0.can someone help me by giving the right step by step guidelines to test the usb cable using minicom or any other serial port utility? :o

31504[/snapback]

before connecting phone type command at prompt( terminal )..

dmesg

after connect again type same command and see diff.. it now shows what happens during u connected usb device.

also shows where is actully mounted the device.

use that instead /dev/ttyUSB0.

Share this post


Link to post
Share on other sites
avkavk    0
in My FC3 which came with pcquest , i can see the usb serial converter listed in the usbview menu, but i cant connect using /dev/ttyUSB0.can someone help me by giving the right step by step guidelines to test the usb cable using minicom or any other serial port utility? :o

31504[/snapback]

Yes it is known issue and USB ports will not work properly on PCquest linux since it uses a slightly different kernel from Fedora Core 3. I would suggest that you should always stick to the kernel that stable Fedora core uses in this case the kernel version that shipped with fedora core 3. You can burn 4 cd's and install Fedora core 3 USB should work properly there.

Also when you want to update any package make sure you update it only from the fedora core update site based rpm or a generic rpm for i386 or i686 or for Athlon in case you are using AMD ( By the way I am using AMD Athlon XP 2600 with 1 Gig of RAM )

Share this post


Link to post
Share on other sites
Ganesh    0

I am also using AMD athlon barton 2600XP. what RPM should i install.. please help meeeh

Share this post


Link to post
Share on other sites
dacodecz    0
I am also using AMD athlon barton 2600XP. what RPM should i install.. please help meeeh

31552[/snapback]

Dear ganesh,

What do you mean by which rpm, are you talking about kernel rpm ?

Cheers ........................................

Share this post


Link to post
Share on other sites
Dhananajay    0

HI all,

after much strugle , i am connected to Internet from my Linux OS

here is the complete set of steps i followed (it took me 4 months and N number of Hr to Connect to Internet)

To Connect to Internet using Reliance Phone (any)

with Fedora core 3

I create a file in /etc/wvdial.conf

1.file:/etc/wvdial.conf

[Modem0]

Modem= /dev/ttyACM0

Baud= 115200

SetVolume=0

DialCommand= ATDT

FlowControl= Hardware(CRTSCTS)

[Dialer R]

Username= my phone number

Password= my phone number

Phone= #777

Stupid Mode= 1

Inherits= Modem0

2. edit following file as follow

file:/etc/resolv.conf

service named start

nameserver 202.138.103.100

nameserver 202.138.97.193

nameserver 127.0.0.1

3. change Mobile\settings\phone\datarate = 115200

4. now to dial to Internet we need to follow these things

5. Connect Mobile to system using a USB cable

6. login as root

7. type following command

modprobe uhci

modprobe usbserial

modprobe ftdi_sio

wvdial R

Huuuuure I am connected to Internet

to disconnect

killall pppd

remove phone after some time

;)

Share this post


Link to post
Share on other sites
dacodecz    0
HI all,

after much strugle , i am connected to Internet from my Linux OS

here is the complete set of steps i followed (it took me 4 months and N number of Hr to Connect to Internet)

Hello :-)

Awwwww, had you been visited our site before you would been using

r-connect very long back.

Anway cheers for you ..............

To Connect to Internet using Reliance Phone (any)

with Fedora core 3

I create a file in /etc/wvdial.conf

1.file:/etc/wvdial.conf

[Modem0]

Modem= /dev/ttyACM0

Baud= 115200

SetVolume=0

DialCommand= ATDT

FlowControl= Hardware(CRTSCTS)

[Dialer R]

Username= my phone number

Password= my phone number

Phone= #777

Stupid Mode= 1

Inherits= Modem0

2. edit following file as follow

file:/etc/resolv.conf

service named start

nameserver 202.138.103.100

nameserver 202.138.97.193

nameserver 127.0.0.1

3. change Mobile\settings\phone\datarate = 115200

4. now to dial to Internet we need to follow these things

5. Connect  Mobile to system using a USB cable

6. login as root

7. type following command

modprobe uhci

modprobe usbserial

modprobe ftdi_sio

wvdial R

Huuuuure I am connected to Internet

to disconnect

killall pppd

remove phone after some time

;)

32240[/snapback]

are you sure the device node you are using is

/dev/ttyACM0

I think you need to check your configuration again,

/dev/ttyACM* entry is generated by the kernel module cdc-acm.ko, and

it's required by the phone havig native usb interface with ACM standard

implemented in it.

But according to your listed configuration device file should be

/dev/ttyUSB*

BTW have you fiddled with udev naming for the said device node :-)

Cheers ..............................

Share this post


Link to post
Share on other sites
abhi84nandi    0
:grin:

Here is how you can configure the RConnect modem on Fedora core. You have to use kppp to dial. Just configure the settings as per the image given below and you are done. It works great with speed up to almost 110 kbps and no line drops stays connected untill you drop the line.

While creating modem either select ttyS0 if you have serial cable and

/dev/usb/ttyACM0  if you are using USB port. Replace the 0 with the appropriate port number here it can range from 0 to 4 or even more depending upon how many serial and usb ports that you  have. Replace the Initialization string with that one which is suitable for your phone. You can find this string in the linux driver that reliance ships on its web site or just call them and they will tell you or use google or go through the manual that accompanies your phone.

Just works ...

No more hassles and pain.

30892[/snapback]

I had redhat 9.0 installed in my computer.Rconnect 1.0 worked fine in it. But now I have installed fedora core 3.0 abd rconnect 1.0 is installed in it.But I CAN NOT SEE ANY WEB PAGE.PLEASE HELP.....

PLZ email me at abhi84nandi@yahoo.com

Share this post


Link to post
Share on other sites
kagashe    1

Hi,

I would like to share my experience of downloading the Linux driver from Relianceinfocom web site, modifying it to suite my Linux distribution and use it successfully.

I have GTran GC4020 handset but the method can work for any handset.

I downloaded the tar.gz file and installed it as per procedure and tried to connect. I was getting an error that pppd could not find the device.

I looked at rconnect.conf file in /etc/rconnect and found that pppd was looking for the device in /dev/input folder as ttyACM0 whereas the PC was linking the device differently.

Initially I used Mandrake Linux 9.1 and found the device was located at /dev/usb/acm/0

I changed the rconnect.conf file so as to point to the device and it started working.

Recently I installed Ubuntu 5.04 and found that the device was located at /dev/ttyACM0 and once again modified the file and it worked.

How I located the device link?

By reading /var/log/messages

I am confident that the driver can work for any Linux distribution after trying it in Mandrake Linux and Ubuntu.

kagashe

<TOPIC MOVED!>

Edited by Vishal Gupta

Share this post


Link to post
Share on other sites
dhgupta    0

Hi all..

...I just joined this forum..cause making this reliance phone connect to the net has driven me mad....I am using Red Hat 9.0 with recompiled kernel 2.4.18......

...I have an LG 2030 phone.... I have tried every trick on the web...but have failed...

...Problem is.... when I do the modprobe thing....and then check the syslog...it shows the driver and all as detected..however it doesnot show the message saying "ftdi converter detected at ttyusb0 "..or any other port.....

Every website shows that the above message is displayed after modprobe ftdi_sio...

...However it is not so in my case.....the usb cable is being detected however.....

PLEASE...PLEASE...HELP ME....PLEASE......

any solution???

dg

Share this post


Link to post
Share on other sites
sas    0

Hi,

I am trying to connect to internet from FC3 via nokia(reliance-CDMA)-6225. But everytime during connection setup, it fails saying "NO CARRIER". Please let me know if you have tried any nokia(CDMA)-Linux combination? Thanks in advance.

--

Cheers

~Sas

PS. I used all the extra initialization command like AT+CRM=30, +CSO=33

:help:

Share this post


Link to post
Share on other sites
Aijaz    0
HI all,

after much strugle , i am connected to Internet from my Linux OS

here is the complete set of steps i followed (it took me 4 months and N number of Hr to Connect to Internet)

Hello :-)

Awwwww, had you been visited our site before you would been using

r-connect very long back.

Anway cheers for you ..............

To Connect to Internet using Reliance Phone (any)

with Fedora core 3

I create a file in /etc/wvdial.conf

1.file:/etc/wvdial.conf

[Modem0]

Modem= /dev/ttyACM0

Baud= 115200

SetVolume=0

DialCommand= ATDT

FlowControl= Hardware(CRTSCTS)

[Dialer R]

Username= my phone number

Password= my phone number

Phone= #777

Stupid Mode= 1

Inherits= Modem0

2. edit following file as follow

file:/etc/resolv.conf

service named start

nameserver 202.138.103.100

nameserver 202.138.97.193

nameserver 127.0.0.1

3. change Mobile\settings\phone\datarate = 115200

4. now to dial to Internet we need to follow these things

5. Connect  Mobile to system using a USB cable

6. login as root

7. type following command

modprobe uhci

modprobe usbserial

modprobe ftdi_sio

wvdial R

Huuuuure I am connected to Internet

to disconnect

killall pppd

remove phone after some time

:P

32240[/snapback]

are you sure the device node you are using is

/dev/ttyACM0

I think you need to check your configuration again,

/dev/ttyACM* entry is generated by the kernel module cdc-acm.ko, and

it's required by the phone havig native usb interface with ACM standard

implemented in it.

But according to your listed configuration device file should be

/dev/ttyUSB*

BTW have you fiddled with udev naming for the said device node :-)

Cheers ..............................

32243[/snapback]

What do you mean by:

3. change Mobile\settings\phone\datarate = 115200

AA

Share this post


Link to post
Share on other sites
Arun    789

Under the Settings menu of your handset, there should be an option for changing the data baud rate.

Share this post


Link to post
Share on other sites
dhgupta    0

Hi,

Me and my friend had been trying to connect to the net on Linux using a Reliance LG 2030 and Silicon Labs USB Cable ( the culprit!!!). Finally after 2 months of hard work, internet surfing and several linux compilations later, we finally found the solution. Any one else having the same problem, can refer to the following:

We used Knoppix Linux 3.9 with kernel version 2.6.12.2.

1) Download 2.6.x kernel source and untar it.

2) In the kernel source directory, do "make menuconfig"

3) Under USB devices, select USB serial support sub heading. In this, select the CP2101 driver as module. Also select the USB serial support.

4) Do "make","make modules", "make modules_install", "make install".

5) Modify the grub to boot to new kernel.

6) Reboot into new kernel.

7) Do "modprobe usbserial" and " modprobe cp2101" as root.

8) Run the wvdialconf script available on the net.

9) Get connected and Njoy!!!

Share this post


Link to post
Share on other sites
Arun    789

thanks for the headsup dhgupta, should come in handy for many trying out R-Connect with Linux.

Share this post


Link to post
Share on other sites
rmisra9    0

hey guys.

I'm trying to configure my Nokia 6255 to connect via bluetooth on linux (Fedora Core 4), and though i've managed to get the bluetooth running, i have no idea of the nokia modem command codes. Looking around, nobody seems to have mentioned them before.

I can get the phone to dial out, but have no idea of the connect code, so it just keeps on dialing.

An email to Nokia about the command codes was fruitless, and i was told Nokia phones do not currently support linux, and that i should use windows!

Anybody got some idea about this?

Share this post


Link to post
Share on other sites
concon    0

Hi,

I am using a Nokia 2112 RIM handset.

I want to get this to work on FC4. Can some one help me?

Cheers,

Share this post


Link to post
Share on other sites
simrel    0

I am using a local usb cable to connect my laptop to a 2030 lg phone and it works fine under win xp.

I want to use the same thing under linux fc4. Does anyone know which drivers to use.

WIndows lists it as an Ark MIcro usb to serial device.

Thanks

simrel

Share this post


Link to post
Share on other sites
gulluu    0

hi

i am using cierra wireless card for net access on win xp, i want to use it on my laptop with mandrake lynux, can anyone help me please?

Share this post


Link to post
Share on other sites
dks89    0

Hi,

I am using RADHET 9 linux, it is just now i am new in LINUX.

When i am going to activate my FWP with GENOME gui, it is giving error 2 or 8.

But when i am going in root and after changing in wvdial.conf file. It is connecting but i don't know how can i go for internet in command mode. i mean to say how can i browse a webpage in root, pls explain if anybody have LINUX knowledge.

After connection of FWP in root i switch to GUI mode but i am unable to access in web page.

pls help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×